Hello Guest it is October 14, 2019, 07:38:16 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Hans1904

Pages: 1
1
No, the methods given in the manual ,10.8.7, were not working. I got in touch with "Chip," who had posted and actually is located in
Gainesville, FL, USA, where I am. He said to place the subs at the end o the main program, in the same file, after the M30 and separated by a % on a line by itself. That does work, and is fine with me, but don't know why the manual does not refer to this.
I am quite familiar with the Haas VF controls (work with one every day), and they do this, too, as one way of using subs. They refer to
it as a "local" subprogram and call it from the main program with M97. Very convenient, but wouldn't know Mach 3 does this without the forum contacts. Now, I couold really use something like a GOTO command as used in Fanuc controls. Thanks.

2

Posts: 1


View Profile Email Personal Message (Online)
   
   
Re: Plugin to use with cnc4pc modio pcb
« Reply #2 on: May 18, 2009, 09:07:44 AM »
   Reply with quote Modify message Remove message
I am working with a Mach 3-controlled machine, trying to get subroutines to work. Am familiar with the usual Fanuc or
Haas formats, but cannot get a main program to pick up the subroutine. Sub is in the "subroutine" folder under Mach 3
folder, as specified. Have tried tried renaming the sub with or without an "O" in its name (It has an "O1000" in its 1st line)
and "%" by itself on first and last line. Any suggestions?

3
General Mach Discussion / Re: Plugin to use with cnc4pc modio pcb
« on: May 18, 2009, 10:07:44 AM »
I am working with a Mach 3-controlled machine, trying to get subroutines to work. Am familiar with the usual Fanuc or
Haas formats, but cannot get a main program to pick up the subroutine. Sub is in the "subroutine" folder under Mach 3
folder, as specified. Have tried tried renaming the sub with or without an "O" in its name (It has an "O1000" in its 1st line)
and "%" by itself on first and last line. Any suggestions?

Pages: 1