Hello Guest it is September 28, 2021, 01:41:47 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - sharbold

Pages: 1 2 3 »
1
Works in progress / 4 Axis Hotwire Foam Screen
« on: December 27, 2009, 04:55:18 PM »
I am in the process of building a hotwire foam cutter to cut foam wings for radio controlled airplanes. I use Profili software to generate my wing and then export the design to g-code which I will load into MACH. I had downloaded Scott's aka Poppabear 2and4 axis screen which I used as the basis for this screen. I would like to thank Scott for all his work as all I did was put a new face to his work. I have tried to upload the screenset as a zip file but the system keep giving me an error saying that .zip is not allowable. so here are a few screen shots of the screenset and a link to download the screenset if anyone is interested.

http://odysseywood.us/profili/CNC%20Foam.zip

Sam

2
Mach Screens / Parallel Port 2 Pin Status
« on: October 12, 2009, 12:05:56 AM »
Are there OEM LED codes for monitoring the pin status of a second parallel port? Where might I find the codes? I would like to add a parallel port 2 pin status to a diagnostics screen like the one that exists presently for port1

Thanks
Sam


3
General Mach Discussion / Re: New PlugIn just about done..
« on: July 28, 2009, 09:40:18 PM »
I using my own screen set.

Sam

4
General Mach Discussion / Re: New PlugIn just about done..
« on: July 28, 2009, 11:46:08 AM »
Dave

   I have my macro saved as M650, M651, M652, etc of course on the plugin they are listed as 650, 651 etc.

Sam

5
General Mach Discussion / Re: New PlugIn just about done..
« on: July 28, 2009, 09:04:51 AM »
Scott

   I am in the process of building my machine now so I have been testing the plugin with MACH not being connected to a machine. That said everything I have tried has worked 100%. Reversing the axis worked fine and the macros I added worked well also.

   I would like to thank you for taking the time to make this upgrade to the shuttle pro. For my application the two macro that the old plugin allowed was not enough. So I was looking into other pendants.  Now this will allow me to set up my pendant as I wanted.

Great job !!!!

Thanks
Sam

6
Works in progress / Re: First try at a Screen
« on: March 18, 2009, 08:50:55 AM »
Bill

   Thanks for taking a look. When I run MACH with this screen everything seems to be working (Keep in mind I do not have a machine for MACH to connect to). When I sent this screen to my buddy to try his report back was the problems I listed in my previous post. I am wondering if his problems are in his hardware setup? He did report back that the rest of the screen seemed to function fine including the probes and limits. His machine is setup with just limit switches, no homing switches.

Thanks
Sam

7
Works in progress / Re: First try at a Screen
« on: March 17, 2009, 09:09:31 PM »
Ok I need some Help? As I stated at the beginning of this thread at the present time I do not have a machine on which to test my screen design. So I had a buddy agree to test it for me. Since he uses a router instead of a spindle I made a few changes to my screen to work more with his setup. Here are the problems that I could not solve.

when I press the Laser Off button the button for the router changes to green and router on ( even thou the router doesnt come on )click again and the crosshairs go off and the router button changes back to router off and red however if you click on the router button, the router comes on but the button doesnt change to the green color

One thing i noticed is the Home key does not work, when i press home on the key pad it usually Zero's all axis.


I am hoping that someone will be willing to take a look at my screenset and tell me where I went wrong!! I have double checked my button codes and in my small mind they look fine. Also when I run MACH using this screen set I cannot get the above results. Any and all help will be welcomed.

Here is a screen shot of the revised screen along with a zip file with all the files. I have placed all the jpg and png files in a folder labeled (Woody) inside the bitmaps folder of MACH.

8
PoKeys / Using the PoKeys in a Pendant (Questions)
« on: March 16, 2009, 05:18:30 PM »
I will soon be starting to build a CNC Wood Router. Until I am able to start my build I have been working on a screenset an a pendant to use on my system. Before I get to far along with the pendant I have a few questions as to the operation using PoKeys. Please forgive me for all the dumb questions. Because of the different items I will be doing on my machine I have 7 different probe scripts that I will be using. I have purchased a Shuttle Pro but have found out that I can only use 2 custom scripts with it. So I am looking into the PoKeys. My plans are to use a series of momentary push button switches as input devices to the PoKeys to control my machine.

1) Using screen4 if I assign a Hot Key to each script button then assign the same key assignments in Pokeys when a button on my pendant is pressed my machine should carryout the script the same as if I had invoked it from my MACH screen, correct?

2) By assigning Hot Key values like (shift + right arrow) to jog X+ in my screenset and to a button on my pendant I should be able to jog my machine, correct?

3) Does anyone have the physical dimensions of the PoKeys unit?

I know this is not the most ideal way to control the machine but is there any reason the above should not work?

Thanks for your help
Sam

9
Works in progress / Re: First try at a Screen
« on: March 13, 2009, 12:06:33 AM »
RC, Scott, Dave

   Thanks so much for the compliments. In a couple of days after a little more testing I will post the .set files if anyone is interested in using the screen.

Sam

10
Works in progress / Re: First try at a Screen
« on: March 11, 2009, 10:00:55 PM »
RC thanks for the compliment. Here is a new screen shot

Pages: 1 2 3 »