Hello Guest it is November 27, 2022, 08:15:52 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Richland Rick

Pages: 1
1
If anyone ever finds this thread looking for the same problem I experienced, the problem getting the torch on/off relay appeared to be a complication of trying to use the Proma THC.  Without the proma THC inputs enabled, the relay works just fine and the torch turns on and off just like it is supposed to. 

I'm quite frustrated with the Proma THC and the lack of guidance for setting Mach 3 to use this device.   Time to do some more Proma research and possible start a new thread. 

2
Assuming my choice of pins is correct, and knowing that if I apply 5VDC to the solid state relay the torch fires, it seems safe to assume that the relay is not getting the signal from the computer to fire.

This statement "when you want the torch to turn on, you will drop that pin to 0 volts and the +5 volts of the power supply will turn it on" leads me to believe the Mach settings should be low active.  Is that correct?

Anyone have a basic xml file for a plasma machine using relays.

I probably should have mentioned that I have a Proma THC connected using the HobbyCNC boards input pins.  It comes to life when the HobbyCNC board is turned on.  Could this somehow be affecting the ability of Mach to turn on the torch?

3
the motor control is being handled by a Hobbycnc EZ board.  It is functioning properly, the XYZ stepper motors are working properly.  The Hobbycnc board does not have outputs other than for the XYZ motors, so I have added a "CNC signal control center" in line ahead of the Hobbycnc board.  The "CNC signal control center" is from Brent Hubbard. 

The control center allows for the parallel port signals to be either passed through to the HobbyCNC board or diverted to a separate set of screw terminals for inputs and outputs.   I'm currently using PIN 16 as my spindle output pin and pin 18 as my -5VDC connection.

According to Brent, "the 5vdc negative must go to ground to give a return path for the signal.   On the negative terminal of the solid state relay (SSR) you will apply a +5volt signal from your control pin from the computer and when you want the torch to turn on, you will drop that pin to 0 volts and the +5 volts of the power supply will turn it on. This will only happen if the negative of the 5vdc power supply is connected to the computer ground.

Am I wrong assuming in assuming pin 18 qualifies as a computer ground?




4
Hello all,

I've been using Mach for mills and lathes for about 7 years.  Now I'm trying to get a rudimentary plasma table functional, but can't seem to get Mach to light off the torch.

My relays function properly and will turn on the torch when inputs are given, but I'm not getting the signal to the relays. 

Going to Ports and Pins, Spindle Setup, Output 1 is selected for M3 and M4 and the "disable spindle relays" box is unchecked.

On output signals, Output 1 is enabled, port 1 is selected, and Pin 16 is entered.  I started with pin 10, but changed to pin 16 after doing some reading here.  I have verified the common is good using pin 18 for the +5v ground.  The positive lead is going to the solid state relay.  this relay functions and the torch fires when given both the +5V and ground.

This tells me I'm not getting the signal from the computer to the relay. 

Here some more info.

On motor outputs spindle is not enabled.

Back to spindle Setup tab, I'm not really sure what to do with the motor control field of this tab.



On motor output spindle is not enabled.


Pages: 1