Hello Guest it is December 07, 2021, 01:54:32 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - BigZ

Pages: 1 2 »
1
General Mach Discussion / Slaving more than 2 steepers
« on: October 30, 2009, 04:10:15 AM »
Is their anyway of slaving 16 stepper motors(yes 16 its not a typo). I am in the early stages of designing something similar to a multi rip saw for putting V grooves in internal doors.

2
Good news. I am back up and running after following your advice. Thanks Lee.

I did notice that if I have duplicate commands on different sticks and conflict the the command, I end up with the same error.

I have noticed though when jogging with one axis the jog speed is 1/2 of max s ther a way of altering this. I do have my jog speed set at 100%?

Many thanks Liam




3
Thanks for your time Lee. I will give that a go.

I bought a chatpad frm ebay. Luckly I bought it cheap as Microsoft hasn't released a driver even though it advertised as being Xbox and PC compatable.

Liam

4
Lee have managed to replicate the problem when transferring my XML file from the machines computer to the home PC.

5
Problem fixed. Handn't saved the A axis setting to match X.DOHHH

6
I have been using my machine with slaved X axis for 2 years with no problem.

I am now running Mach3 3.041. My machine works fine and doesnt lose steps at any speed range. Untill I home or verify then one motor is definately faster than the other. Any ideas would be appreciated?

Regards

Liam

7
To get the controller working I was using MACH3 V2.63 with Xbox360_32Eng.exe and Nov2007 DirectX SDK files installed. All worked OK.

The next day it still worked just I reconfigured the buttons to suit and everything worked fine.

On the third day I recieved the error message on startup. My only file change was to delete the plugin file after the error. Mach then started up as normal. Since then I upgraded to 3.041 added the plugin ande recieved the same error on startup.

Lee I appreciate the time your taking on this.

I have a Xbox messenger on order . So will let you know the results(testing it on the home PC)


8
Hi Lee

I was using R2.63. I have upgraded to 3.041 as suggested but problem still persists.

Liam

9
Hi Lee look forward to the future updates.

Unfortunately I ran into a problem today. When starting up Mach3 I get an ""Error Code Art 904. Attempt Recovery".

Unfortunately the program dosn't recover unless I remove the Xbox plugin and reopen Mach3. I have had this plugin working on this computer and have not changed any settings since. Any ideas on how to fix it would be appreciated?

Regards Liam



10
Hi BigZ,

If you are refering to the addin keypad that Microsoft offers for the Controller, the answer is, it should work but I am not sure.  As I understand it, the keypad is really just a USB keyboard that uses the XBox360 controller as a pathway for communication.  If you hook up the keypad to the controller and it starts working like a keyboard, then it should work.  Try it and let me know.  If it gives you any error messages, let me know what they are. I might have to add the productId of the keypad, but I don't think so.

Lee



Lee thank you for such a great plugin and the foolproof instructions( only recieved my XBox controller yesterday).

I am only thinking of buying the messenger pad as I would like to add my camera edge finder offset and zero plate to my controller. I do have some spare buttons left but couldn't work out if I could configure it for hotkeys.

Any plans to get all the buttons working? Just a suggestion would it be possible to expand the joystick menus to include all the functions listed in the button menu?

Great work Lee

Liam

Pages: 1 2 »