Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: dfurlano on October 30, 2008, 10:03:18 PM

Title: I'm lost
Post by: dfurlano on October 30, 2008, 10:03:18 PM
I have been continuing to struggle trying to get a new G540 to work properly.  Every time I think I got it I end up not even close.

For some unknown reason I am losing position on the Z.  I tried tuning the motor down to a velocity of 25 and acceleration of 5 and nothing changed.  On a 3d contour I am losing 0.2" of height in 10 minutes of running for some reason always gain height.

Also I have no idea why when I turn my shuttlepro dial real slow the DRO changes on the screen but the motor does not move (all axis).  Once that happens I can crank the shuttlepro and the DRO responds but not the motor.

I tried updating the Shuttlepro driver.  Tried a different version of Mach3 .  Turned backlash on/off, CV on/off, enhanced plusing on/off.

I checked electrical connections.  Mechanical connections.  Ran the drive test.  1.8gz Pentium V, Geckco G540, Keling 48V PS, 2 pacsci motors and 2 generic 276oz Nema 23 motors.

I am lost on what to do or even try.

Dan
Title: Re: I'm lost
Post by: dfurlano on October 30, 2008, 10:54:11 PM
Well I tried both 1/2 step sherline mode and setting the pulse to 5.  I have gotten farther then before and the z is working correctly after about 20 minutes.  I will run it more tomorrow.

Before it acted like a buffer got full.  I would lose position on the Z and not be able ot use the shuttle then I would exit mach and restart the program and the shuttle would respond normally.

Dan
Title: Re: I'm lost
Post by: jimpinder on November 01, 2008, 05:58:54 AM
Has this fault just occured since you installed a new Gecko driver ?? ( I have no explanation - but just need to understand the problem)

Was the machine working correctly before.

I had a problem with my miller, becasue the Z axis was sprung upwards, and my motor was not powerful enough to force it down against the spring. I reworked the spring and put in a more powerful motor - it's fine now, but I need a new driver.

The other thing that has been mentioned in this forum is that Geckos have optical isolation on the inputs, If your Bob board also has optical isolation, the first pulses of each move were lost, resulting in "creep" on the axis in one direction. This fault was retified by feeding the Gecko directly from the LPT1 output and avoiding the Bob on the drive pins.


Title: Re: I'm lost
Post by: dfurlano on November 01, 2008, 06:48:10 AM
I had a Xylotex controller for about two years then the power supply blew and fried the board.   

I got it working but I don't really know why or even exactly how.  The only thing I can tell you is that I have two Pacsci motors on the X-Y and two generic NEMA 23 motors on the Z and A.  When I first set up the machine I focused my efforts on the X-Y.  All seemed well.  Then I started cutting parts and the Z displayed the issues above.

I changed the pulse rate to 5 and checked the 1/2 step sherline mode and now the shuttle and z work fine.  The Pacsci motors are unaffected by the change. 

For me every time I make a change to the electronics there is a week or two of guessing what settings will work.  I tried the Gecko XML file but that was actually more trouble then it was worth.

The Gecko G540 gave me a huge increase in speed and stability.  The Pacsci motors are amazing motors with the Gecko controller.  Overall very happy with the new system.
Title: Re: I'm lost
Post by: RICH on November 01, 2008, 09:35:20 AM
Dan,
Curoius on how your mill quill  or mill head is mechanicaly driven up or down.
RICH
Title: Re: I'm lost
Post by: dfurlano on November 01, 2008, 10:10:29 AM
It is a mini mill head with a spring attached.
Title: Re: I'm lost
Post by: RICH on November 01, 2008, 12:29:56 PM
Dan,
For some unknown reason I am losing position on the Z.
Just trying to read into the postings and frankly still trying to understand.
So you had a controller that got fried and you "fixed it" but don't know how or why it now works ?
So what is your controller comprised of now? ie; part Xylotex and part Gecko for drives?
I usualy try to understand and eliminate the mechanaical side of things. Do you have a picture of the spring assisted
head and what is driving the mill head up and down?As jimpinder has pointed out, the mechanical can influence the
other parts of the system. With the shuttlepro disconnected does everything work fine?
RICH

Title: Re: I'm lost
Post by: dfurlano on November 01, 2008, 12:48:31 PM
For over two years I had a Xylotex based controller that I purchased from KDNtool.  I had it running my mini mill with the two Pacsci motors and two generic NEMA 23 motors.  Everything was working well no issues for two years.

A while ago the power supply blew in the KDNtool controller and the Xylotex board was effected, I was limping along but the board needed repair.  I was going to get the Xylotex fixed but I then decided to throw out the old controller and buy the Gecko G540.

I know have a Gecko G540 and a Keling 48v PS. 

The Z axis losing position had nothing to do with the spring or the head.  Somehow NOT having the pulse rate set to 5 and/or the shireline 1/2 step on (don't know which helped I did not test them separately) causes the Z to lose position and it causes the shuttlepro to not work properly.  I never tried to disconnect the shuttlepro I did download the latest driver and I also tried Mach version 3.xx just to see if that would help.

As I stated I don't know why but that is the way it is.  I am one the road most of today but would be happy to post some photos later.

Dan
Title: Re: I'm lost
Post by: RICH on November 01, 2008, 02:25:15 PM
Dan,
No need to post photo's since if all was fine before on the mechanical side then it should still be to you standard.
Since you post two problems, how about eliminating one by taking the shuttlepro out of the problem and then simply
swaping the x,y or A axis for the Z axis, since they are working correctly, and see if you can narrow things down.
Don't have a g540, but assume your wired thru correctly, have followed Gecko info on motor info and, and that the
current set resistor is giving you the equivilant torque that you had before.
RICH
Title: Re: I'm lost
Post by: fixittt on November 02, 2008, 10:03:30 AM
it was the sherline 1/2 pulse mode that fixed your problem.  I did basically the same thing and I had axis drift all over the place.  It took me about 4 days to finally check the 1/2 pulse mode and all problems went away.  Everything that gecko support was telling me indicated that the sherline mode COULD NOT BE the problem, they actually said that in the motor tuning the step and dir needs to be 2.   
Title: Re: I'm lost
Post by: dfurlano on November 04, 2008, 03:53:40 PM
Thought I would show how I retrofitted my PC tower with the Gecko G540.   Power supply fit nicely in the bottom inside and you can see the plug and switch on the lower left.

The Gecko's are a huge improvement over the Xylotex and the G540 is very competitively priced.

(http://www.dfurlano.com/tower.jpg)

Dan
Title: Re: I'm lost
Post by: mkaman on November 06, 2008, 08:50:36 PM
Dan,

I just wanted to say thanks for sharing the information on fixing your problem. 

I just picked up a Gecko 250 based system and had the almost .2 inch difference in running a 3d fixture cut for a project.  Work area in the code is 1 inch by 1 inch. 

Enabling the Sherline 1/2 pulse mode worked for me also.  I have the setup down to .0015 inch off at the end of the code now, and am going to change the Step and Dir pluses to see if that helps even more. 

Thanks again,
Michael
Title: Re: I'm lost
Post by: DougO on January 14, 2009, 05:22:12 AM
Just checking to see if the original problem was corrected?  I think I am having the same problem, but only with my z-axis and it only does it after running the motors for 10-15 minutes.  Where do I find the option to select this "1/2 Sherline Mode"?

thanks
Title: Re: I'm lost
Post by: Hood on January 14, 2009, 05:33:20 AM
  Where do I find the option to select this "1/2 Sherline Mode"?

thanks
From config menu then ports and pins, towards the right hand side of the initial page.
Hood
Title: Re: I'm lost
Post by: dfurlano on January 14, 2009, 08:07:22 AM
I have never found what the issue is or why you need to use the sherline mode.   The computer I am running on is a 1.8 AMD with a gig of ram.  There is no onboard video and I do not run anything but Mach3 on this system.

I do like the Gecko over the Xylotex controller it is a much more robust system.

I would like to get the smoothstepper at some point when they have 100% compatibility. 
Title: Re: I'm lost
Post by: DougO on January 15, 2009, 07:54:34 PM
Well blow me down (isn't that what Popeye used to say).  I run my machine till everything warmed up and I started missing steps.  I then went to Mach and checked the Sherline 1/2 pulse mode box and haven't missed a step since.  I could see the exact spot I was missing the steps and Have no idea what that does, but it works and that is all I care.

thanks for the help guys,
Doug
Title: Re: I'm lost
Post by: dfurlano on January 15, 2009, 08:47:31 PM
It's a freakin mystery.
Title: Re: I'm lost
Post by: koko76 on April 01, 2009, 12:23:41 PM
If it helps any I was/am in the same boat.  Either check Sherline mode or lose steps in Z.  I haven't changed the pulse width though.  G540, 48V power supply, keling 387's all around. 
It's not so much that it happens like this, but that there seems to be no logical explanation for why.  Gecko says there is no reason for it to be this way, and it doesn't make sense why it would be.  I've recently upgraded my computer, but I'm still using the old XML.  Perhaps the computer upgrade will have helped some as the old system was a bit on the low side of spec.