Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: elpablito on July 11, 2008, 01:51:52 PM

Title: Problem with pulse width
Post by: elpablito on July 11, 2008, 01:51:52 PM
Hi,

I'm trying to convert a Chinese router that has its own custom controller to Mach3.
I have already succeeded in driving the stepper motors with Mach3, but when moving at feed rates higher than 5000mm/min they sometimes lose steps.
I have compared the signals from Mach3 and those from the original controller with an oscilloscope and they seem to be equal in level and frequency, but the original controller has a pulse width of 50us that I can not find a way to configure with Mach3.
I have tried different settings, including the Sherline mode, but the pulse width is never higher than 20us.

How can I do to set a pulse width of about 50us?

Thanks a lot for your help.

Pablo
Title: Re: Problem with pulse width
Post by: Chip on July 11, 2008, 06:37:21 PM
Hi, Pablo

I think the sherline 1\2 step mode is the widest pules width Mach has.

Some stepper controls are sensitive to leading and trailing Edge Pulses (Dir, Step pulses, X'ed or Checked).

Try them both ways, Ether "All" Checked or X, "Your Axis Directions will Reverse", So be Care-Full (Test center of Table).

Direction change should be set in Home & Limits page (Reversed Coll-um).

Hope this Helps, Chip
Title: Re: Problem with pulse width
Post by: jimpinder on July 12, 2008, 03:48:08 AM
I must assume that the original chinese drivers would go faster than 5000mm/min or you wouldn't be asking.

Try turning the kernel speed up (Config/Ports and Pins - first page, bottom left)