Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: Tom Nelson on April 13, 2008, 04:45:42 PM

Title: Help
Post by: Tom Nelson on April 13, 2008, 04:45:42 PM
I have ran the driver test program and for pulses per second in 25khz I'm getting from 95 to 97  I don't know if its any help but the cpu speed is 799 and the light for "Apic is present" is lit.
I can move the motors but very slowly. I have uninstall the driver and reinstalled and rebooted but no help.
I see lots of questions but with no answers on this site. I hope for so help!!!!!!!!!!

Title: Re: Help
Post by: suthy on April 13, 2008, 04:49:23 PM

Try pressing shift and cursor.Also press tab and adjust jog speed up from 5 %
Title: Re: Help
Post by: Chip on April 13, 2008, 06:42:03 PM
Hi Tom

Click on the Feed-rate DRO and set the value to your Velocity setting in your Motor Tuning page.

Hit the TAB key and set the Slow Jog Rate to 100%.

Should Help, Chip
Title: Re: Help
Post by: jimpinder on April 14, 2008, 08:49:15 AM
So - you are getting movement :D be happy !!!

You now have to begin the hard work and set the machine up. We assume you must have done the Ports and Pins to get the axis moving at all. Go to Config/Motor Tuning and set up your axis motors. As a quick guide 1/8 step motors, 200 steps per rev/ 10 revs per inch = 16000 per inch. alter you figures to suit but that gives you the idea.

I don't know what machine you have but set the speed at a very conservative 5 units per min. If this works keep putting the figure up til your motors baulk at it and step back down a bit.
Set acceleration at 1, the pulse time at 3 SAVE EACH AXIS SEPERATELY OR IT WILL REVERT.

This should get you speeded up.
As somebody mentioned above - when jogging - have a look at the jogging %. This is the percentage of the speed you have set under Config. To move at FULL SPEED press "shift" with the "jog" key.