Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: tnsmachines on October 09, 2007, 09:07:43 PM

Title: motors won't move
Post by: tnsmachines on October 09, 2007, 09:07:43 PM
I have installed the Mach 3 system on my computer and downloaded a Galil plugin. The system worked but with some issues. So I hooked up the Gecko system with just one motor. I set all of the parameters as needed. When I turn on the system the driver will hold the motor. But when I try to move the motor with the jog or any MDI instruction nothing happens. I have double (triple) checked all of my settings and don't see anything wrong. I checked the forum and found where someone else had the same problem. I downloaded the file sent to them and installed it on my computer (I am afraid it was an older version of Mach 3 but I'm not sure). It found the license and re-installed. Still nothing. I changed the driver and the I/O board and tried again. Still no movement.
Any ideas?
Title: Re: motors won't move
Post by: Chaoticone on October 09, 2007, 10:22:26 PM
On the program run screen, Jog Enable, is it turned on?

Title: Re: motors won't move
Post by: jimpinder on October 10, 2007, 06:38:39 AM
Are you getting ANY output on your breakout board from the computer.

Ignore the motor drivers and set up outputs for say M3 on ANY of the pins 2 to 9 and 1,14,16 and 17.

By running Mach3 then doing M3 followed by M5 you can see if the appropriate pin changes voltage. The voltage should change from 0V or close to it, to either 3.5 volts or about 4.75 volts. If you comfigure Active Low, then these will be reversed. Change the pin allocation and try again. You should be able to check all your output pins in this way. Ensure you have a good signal ground on your connecting cable.

If you are getting voltage changes on all the pins, then Mach3 is fine and you need to look at your drives. If you are not getting any voltage change then your configuration is wrong. I assume you have ticked port 1 as enabled and also put in port 1 on the ports and pins allocation.
Title: Re: motors won't move
Post by: tnsmachines on October 10, 2007, 09:10:10 AM
Yes the jog is hi-lited. And the E-stop is solid.
I get 4.2V if I check from the ground pin to a hot pin on my parallel cable (Not connected to the I/O but connected to the computer's LPT1. But if I check from ground on my I/O to the 5V pin I get only 2.2V. Checking the voltage at the E-Stop (Pin 10 in this case) I get nothing whether it is active or not. I have tried "active high" and "active low" on my E-stop, motors, etc. I only have one motor connected at this time for testing.
I have port 1 enabled and also port 1 on the ports and pins allocation.
I am using a CNC4PC I/O board. I have not connected a seperate 5V power supply. I was expecting to get the 5V through the computer cable. I will try connecting the power supply first.
I am not sure why the Gecko boards require the configuration for 5V as follows:

•  The common terminal to pins 2-9 can be ground or +5vdc. The board has a jumper that allows you to select if the common terminal to pins 2-9 will carry a ground or +5vdc. So if you are connecting encoders or proximity switches, you can select it to ground. If you are connecting Geckodrives or limit switches, you can set it to be +5vdc.
Any idea why the common would need to be 5Vdc?

• External Enable Pin (EN). The board has a pin that allows you enable/disable all the outputs at once. The board requires +5vdc in the EN pin. If it is not present, it will send all the outputs to ground immediately. You can use this enable and disable your system manually, or you can install an external Safety Charge Pump or other external device.

I am connecting the 5Vdc now. I'm not sure where the 2.2Vdc that is already present comes from unless the 4.2Vdc that is supplied by the computer is resisted to 2.2Vdc. Any ideas?
Title: Re: motors won't move
Post by: tnsmachines on October 10, 2007, 09:50:38 AM
After connecting to the 5V from the computer power supply on the CNC4PC Model C10 I/O board I now have a constant 5Vdc to the #10 E-stop pin. I have the #10 pin on the I/O jumpered to the 5V pin beside it. Clicking on the Reset icon does not change this voltage. But I am not sure they are connected.
I have enabled the spindle to use pins 3 and 4 for M3 and M4 commands. There is no voltage no matter what command I give the control whether M3, M4, or M5. I think this should change state to either 5Vdc or 0V, correct?
Title: Re: motors won't move
Post by: tnsmachines on October 10, 2007, 12:55:48 PM
Does anyone have any ideas?
Title: Re: motors won't move
Post by: jimpinder on October 10, 2007, 12:56:48 PM
I have had a look at the CNC4PC board and it seems totally misleading and difficult to follow.

1.   You must have a 5 volt supply connected to this board. The standard 25 pin LPT1 output from your computer DOES NOT supply a 5 volt power source. My stepper motor driver boards are 24 volt and derive a 5 volt supply from that - perhaps Geeko are the same and you can use that - I don't know.
2.   Despite what is said - pins 2 to 9 on LPT1 are only OUTPUT pins and cannot be used for inputs. The other output pins are 1,14,16 and 17. The input pins are numbers 10,11,12,13 and 15.
3.   The "common" for pins 2 to 9 and other outputs need to be set to 0 volts. The common for the inputs can be either depending on their use.
4.   Ensure the "Enable" pin on the top right hand corner of the board is jumpered to 5 volts
5.   I must assume that 0 volts on the card is connected to the 0 volts on the printer cable (pins 18 to 25), so therefore the only connections you need to the stepper driver boards are pin 2, pin3 and a common (0v) - the one between pins 2 and 3 will do.
If you find this works, then the second motor will be pin 4 and 5 and a common, and so on.

I suspect that, because you are not getting any indications on the card, this is because a) you did not have a seperate power supply to the board, and b) the enable pin was not jumpered. Connect a power supply, jumper the enable pin, and check again to see if there are any outputs, using the M3 M4 M5 routine. You do not need any input pins connecting at this stage.
Title: Re: motors won't move
Post by: tnsmachines on October 10, 2007, 03:00:51 PM
Thanks for your reply.
1) I connected a 5V power supply to the board as per their drawing. (I used an extra power supply cable inside my computer)
I have the unit wired according to the drawing shown on their website at:
2) The jumper for pins 2-9 is on "output" - this works ok
3) I changed the "Com" jumper to "Com" instead of "5Vdc" -------This made the unit work! Their diagram says to use the 5Vdc!
4) The "Enable" jumper is in position (It came with a jumper out of the box, I never removed it)

Thank you for your help! Now, how did you know to set the jumper to "Com" instead of 5Vdc?

I'm not out of the woods yet. The motor only runs in one direction whethe I give an MDI command or jog. This is a Brushed DC motor and drive..
Title: Re: motors won't move
Post by: jimpinder on October 11, 2007, 04:25:35 AM
If you are connecting several electrical boards together (speaking generally), although each can have a seperate power supply, +5v, +12v +3.5 volts or whatever, there must be a COMMON connection between all the boards, or the voltage you supply to it does not have a reference. Voltage does not just exist - it is the potential difference between TWO points - this is why birds can perch on 25,000volt overhead wires - they are only touching one wire.

The accepted norm is to connect all the 0v leads together, so that each board then has the same reference for the voltage they are using - so a +5volt signal from your computer will be recognised as a +5 volt signal by your CNC card. If the Common wire is not common to all boards then your CNC board might see a signal from your computer as being ,say,-15v or indeed just not see a voltage at all.

I note you are using a 5 volt power supply from your computer. This is probably fine, but I do not know what power the CNC board needs. Make sure your computer power supply can supply it.

As far as the motor only spinning one way - I do not know what makes your particular motor reverse.
I use stepper motors and my driver cards require two inputs : one is 'step' and the other is 'direction'. A pulse on the step wire moves the motor one step, and the direction is determined by the voltage on the direction wire. This is the method Art has used on the motor outputs from your PC.

If your motor has a driver card, then you will have to look at the details for that. I have heard of Geeko cards and I would have thought these are the same.

Glad you have something running.

Title: Re: motors won't move
Post by: jimpinder on October 11, 2007, 04:33:25 AM
Just another thought about the motor reverse - try altering the ports and pins - make the reverse active low - (or high if it is low already) and see if this alters your motor running. ( It shouldn't really, but you never know).

The other thing to do is check the voltage on your CNC board on the reverse pin and see if it alters when you reverse the motor, it should do. You won't see full voltage because they are only pulses, but you should see a change.

If you have a hi/lo/pulse detector for computer work then use this, it gives a lot more reliable information.
Title: Re: motors won't move
Post by: Chaoticone on October 11, 2007, 09:58:35 AM
Just thought I would add, If you want to keep the Isolation the board provides, you need to have a seprate 5V supply. Without it, you loose your isolation.