Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: Henrik72000 on April 07, 2019, 06:05:53 AM

Title: mach 3 2.0 problem
Post by: Henrik72000 on April 07, 2019, 06:05:53 AM
I have problems with my cnc not coming back to its 0 point. I have now changed all the guides and repacked my ballscrew spindle. But without result. It is as if the machine loses its location when running a program. Usually when it has run it 3 times ok then the fails begins. DRO shows that the axis is moving but it does not. If I "jog" the spindel and DRO is not moving , but "slow jog" it move the axis it as it should. I have tried to change the cable and switch on the control ports, on the g540, where I have used the port from the a-axis. Also without result. Using Mach 3 - 2.0
I have tried today to change the connectors (DB9) on g540 so that x became the y-axis. The problem moved over to the "new" y-axis. I think that it is the g540 that had an error, but then I made the a-axis to the y-axis the problem was still there !!! Can it be mach 3 that doesn't work properly? Or is the g540 not working?

Title: Re: mach 3 2.0 problem
Post by: reuelt on April 07, 2019, 06:44:11 PM
Not enough info for people to be able to effectively help you.

Which OS?
Motion Controller (make & model) or Parallel port?
Kernel speed if using parallel port
Initial setup or sudden failure?
Stepper motor or closed loop servo motor ?
What is your microstepping setting if using stepper.

I suspect your Y-axis MOTOR is problem NOT G540. Motor is underpowered or you are running too fast or (your kernel speed is too low).
If using steppers, your micro-stepping setting could be unrealistic/incorrect.