Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: Johnansaro on April 19, 2018, 10:49:37 AM

Title: Issues on referencing my Y axis
Post by: Johnansaro on April 19, 2018, 10:49:37 AM
Hi there
I am putting together a 2*5 - meter Wood Cutting router using 750 w delta Servo Motors and ASDA B2 Drivers, The Controller is Mach3 (I am attaching the Picture of it). In this Controller the Y axis is called X therefore, my 2 motors for moving the Y axis is called X1, and X2 in this controller which is no problem so far, should mention that I do not need to slave X1 to X2 or Vice versa, because they actually rotate the Motors in Opposite direction, which is cool.
Everything was working fine, and at my first trial I moved the Motors very smoothly and nicely. I started the referencing process, and everything referenced rather nicely, and I moved to calibration Process, and everything was going fine. But at the end of the day I noticed one of my long axis, Y (which is being powered or moved by two servo Motors X1, x2) motors is lagging slightly. I thought that I should Tight up My Gantry Screws and bolts, which I did the next day, but at a little later time when I tried to reference the Axis, I noticed that My Y axis is not referencing properly, and after moving a little it stops before it reaches my Inductive Home switch, and then it continues to reference my X axis.

After Many Trial
My Z axis Reference properly
My Y Axis Stops before reaching my Home switch
My X axis Reference Properly         

Should mention that My Y axis occasionally referenced properly, but at next trial It again stopped before reaching my Home switch, and at each Trial it traveled a different distance before stopping, and as I tried more it traveled less distance before stopping. And at some Trial one of my Y axis Motors Lagged rather drastically, and a little short circuit at X1 Motor connections happened, which caused me to turn off the Machine, and re wired that connection (My X1 Motor) 

I wonder what could be the cause of it;
1: Could it be because of my faulty cables going to Servo motor from my driver? But if I have a faulty wire or cable or the Motor itself, shouldn’t I get some warning and/or alarm coding from my Drivers? Because I do not get any alarm from my drivers
2: The most suspicious Item to me is my Controller, I think my X1 Plugin is not working properly. Each Plugin contains 4 wires (Direction –) (Direction +) (Pulse –) (Pulse +) Line drive 5V
Any recommendation greatly appreciated

Title: Re: Issues on referencing my Y axis
Post by: ger21 on April 19, 2018, 11:42:51 AM
First, what controller?

When it stops, do the DRO's zero as if it were homed?

My first guess would be noise triggering the home switches.
Title: Re: Issues on referencing my Y axis
Post by: joeaverage on April 19, 2018, 02:14:26 PM
did you ever get electronic gearing sorted and get the controller to pulse fast enough?,36731.0.html (,36731.0.html)

Title: Re: Issues on referencing my Y axis
Post by: Johnansaro on April 20, 2018, 11:40:44 PM
Hi ger21

Yes all dro's zero as if they were homed.

As you said I believe, I have noise problem, I am looking into it.

Title: Re: Issues on referencing my Y axis
Post by: rcaffin on April 21, 2018, 05:49:10 AM
You should also check the wiring on the Y axis Home switch.
Title: Re: Issues on referencing my Y axis
Post by: Johnansaro on April 22, 2018, 03:39:14 PM
Hi there
Problem resolved, since I was using 2 different kind of Home Switch, apparently they created some kind of noise, that after adding some relay switches to my limit switch the problem is resolved and all is fine.