Machsupport Forum

Mach Discussion => Mach3 under Vista => Topic started by: dakes55 on May 31, 2017, 03:06:43 PM

Title: Driver Test Will Not Work in Vista
Post by: dakes55 on May 31, 2017, 03:06:43 PM
I am running Mach3 on 32 bit windows vista and the driver test will not work, I looked in the device manager and saw mach3 pulsing engine, clicked on that and saw the driver but it has a question mark against it, when i go to the Mach3 folder i see the driver test icon, i right click on it and run as administrator, then a box appears on my screen asking me if i want to run the program, I click yes, and the screen just flickers and the program doesnt start, when i was running on xp it all worked fine, any ideas on this one please.
Title: Re: Driver Test Will Not Work in Vista
Post by: Tweakie.CNC on June 01, 2017, 02:13:15 AM
Have you followed the advice given in this post ?,2385.msg14328.html#msg14328

Does your PC meet (or exceed) the minimum requirements ?

Requirements if using the parallel port for machine control:
Desktop PC (Laptops are not supported) with at least one parallel port
32-bit version of Windows 2000, Windows XP, Windows Vista, or Windows 7 (64-bit versions will not work)
1Ghz CPU
Non-integrated Video Card with 32MB RAM(Large G-code files, especially 3D files will require a video card with 512MB RAM or higher)

It is possible that you have a corrupt installation, in which case try deleting the Mach3 folder and reloading Mach3 from scratch (make a backup copy of your original Mach3 folder first).


Title: Re: Driver Test Will Not Work in Vista
Post by: dakes55 on June 01, 2017, 04:10:44 AM
Yes I followed all the advice given in the post, I have a powerful computer 3ghz cpu with 1 gb ram, fresh installation of win vista home premium 32 bit os
parallel port configured correctly, with fresh installation of Mach3, its all working ok apart from not being able to test the driver in explorer and the yellow abnormal condition light flashing  saying axis not configured correctly and cv vs  instantant stop conflict which i cannot change in general config, i ran a test job and it all seems to be working ok, i dont know why the mach3 driver has a question mark against in in device manager.