Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: greenene on April 14, 2015, 08:11:49 AM

Title: Am I losing my mind?
Post by: greenene on April 14, 2015, 08:11:49 AM
I've always had Mach3 on "ignore tool changes", and with an M6 in the code, the machine would stop and allow me to change the tool.  I would hit the cycle start to get it running again. This is no longer the case.  The same program, with an M6 in it, will momentarily pause the machine, and then continue to run.  If I don't stop it, it will run with the wrong tool.

 Before someone tells me that I am using the wrong option in Mach 3, for a very long time I am not able to use the "stop spindle" option because Mach 3 gives me an error which Hood was not able to help me with.  A search in the forum will illustrate that, for some reason, the script in Mach 3, was creating the error.  I finally gave up with the " stop spindle" option and went with the "ignore" option--so long as the machine stopped and allowed me to change the tool.

I was fine with the "ignore tool changes", despite the no warning pop up to change the tool.  

When I run this code on my other pc with Mach3( without the router), the program stops and waits for me to hit "cycle start"---just the way I expect it to behave.

I run the same program from time to time, so no changes in the code were made.  

Hope someone can explain it to me.

Here's a snippet of my code:
N104 T1 M6
N106 G0 G90 G54 X6.3749 Y2.9455 A0. S4278 M3
N108 G43 H1 Z.1
N110 G99 G81 Z-.265 R.1 F26.
N112 X.3774 Y1.3725
N114 X6.3749
N116 X.3774 Y2.9455
N118 G80
N120 X8.0524 Y.3892
N122 G99 G81 Z-.26 R.1 F26.16
N124 X9.1304
N126 X8.0524 Y6.3892
N128 X9.1304
N130 G80
N132 X2.1226 Y4.7493
N134 G99 G81 Z-.29 R.1 F26.16
N136 X.6524 Y4.7471
N138 X2.1226 Y10.7487
N140 X.6497 Y10.7513
N142 G80
N144 X4.4966 Y4.7329
N146 G99 G81 Z-.265 R.1 F26.16
N148 X4.4995 Y10.7319
N150 G80
N152 M5
N154 G91 G28 Z0.
N156 A0.
N158 M01
N160 T2 M6
N162 G0 G90 G54 X3.521 Y3.3047 A0. S4278 M3
N164 G43 H2 Z.25

Title: Re: Am I losing my mind?
Post by: ger21 on April 14, 2015, 12:05:46 PM
Sorry, but I'm not going to search for your previous posts to see what was discussed.

Have you tried completely uninstalling and reinstalling mach3? Or tried a different version.
What you're seeing is not normal, and I've never heard of anyone else seeing this, so I don't have an answer for you.
Title: Re: Am I losing my mind?
Post by: BR549 on April 14, 2015, 10:45:29 PM
IF you use the ignore tool change option it will NOT stop for a tool change it will continue on as you requested it to do .

What you described is Manual Tool Change option. It  stops and waits for you to change the tool and then you press Cycle start to continue.

What version of Mach3 are you running ?

Title: Re: Am I losing my mind?
Post by: greenene on April 15, 2015, 09:19:27 AM
I am running 43.022 version.  Sorry, I did not expect anyone to search my other posts regarding my issue. I was simply emphasizing the fact that the machine no longer stops for a tool change, and I did not make any changes in the code or the config file.  So let me ask, what files do I save in order to retain all my motor and switch settings? thanks
Title: Re: Am I losing my mind?
Post by: BR549 on April 15, 2015, 10:47:13 AM
OK IF you want it to stop at a manual tool change then CHECK(select) the  Manual tool change option. THEN restart Mach3 and check to make sure the setting chnage took place.

You would want to save the MXL file as it contains ALL the machine settings.

(;-) TP
Title: Re: Am I losing my mind?
Post by: ger21 on April 15, 2015, 11:12:09 AM
I would not recommend using 3.043.022. If you edit the M6 macros, they can lock up Mach3 in that version.
Title: Re: Am I losing my mind?
Post by: greenene on April 18, 2015, 05:34:59 AM
changing version number to latest did the trick. Thanks.