Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: JimG on August 23, 2014, 03:05:26 PM

Title: Possible Parallel Port Emulation Problem?
Post by: JimG on August 23, 2014, 03:05:26 PM
My KX1 and PC running Mach3 stopped talking to each other last week after four and a half years of trouble free operation.   I had temporarily connected the PC to the internet to re-activate a copy of DraftSight on it and a load of updates seem to have been downloaded at the same time.   I wasn't aware of the updates until I noticed that the PC was still running after I had supposedly shut it down and when I fired the screen up,  I found it finishing off the installation of several updates.   I let it finish and shut it down.  but when I started the machine up the next day,  the Mach screens were changed and i couldn't talk to the KX1.

I spent a day or two checking everything,  trying to step back through updates to get back to the previous PC state,  then reloading Mach,  PCI card drivers, etc.  but still no luck.   I then dug out an old WinXP machine I had pensioned off a few years back and tried to get it back into working trim.  It had an onboard parallel port,  so should have been easy.  but it would not run Mach properly - i.e. I couldn't get a satisfactory driver test done.

I then went back to the original PC and tried checking the parallel port using Parmon.exe,  but couldn't see changes of the port using Parmon reflected on the output pins.  So I reckoned that the card was faulty and got a replacement.  On trying it today,  I found that port pin setting with Parmon was not being reflected on the output port pins on this replacement card either.   I went digging around on the Internet to see if this problem had occurred to anyone else and actually found someone who had had the same problem.  He had found that a parallel port emulation had been set up in his computer and that was what Parmon was seeing and interacting with.   It looks as though this might be my problem and might have happened after that [expletive deleted] update.   Any help on how I can confirm this,  and get rid of it?