Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: derek on August 08, 2013, 07:49:31 AM

Title: Rotational soft limit issue
Post by: derek on August 08, 2013, 07:49:31 AM
I've redone the config for my mill.
I started with a clean XML. I can't seem to get the rotational soft limits to be ignored. I had no problems with this in the old XML.
I have "Rot 360 Rollover and Ang Short Rot on G0" checked. I have "Rotational Soft Limits" unchecked. I can increase the the distance in "Homing Limits" but that's not really the solution I'm looking for.
I examined the Rotsoft parameter and it was set to 0.

Any thoughts on this or is it yet another "wait for Mach4 issue".

Thanks
Derek
Title: Re: Rotational soft limit issue
Post by: Hood on August 09, 2013, 03:01:53 AM
If you attach your xml I will see if I can find a problem.
Are you using 066 version of Mach? It has some issues with Homing and although I have not heard of that one before it could be.
Hood
Title: Re: Rotational soft limit issue
Post by: derek on August 09, 2013, 04:55:40 PM
Hi Hood
I'm running .056.
My old XML has no issues with this version. This isn't the first time I've had a new XML not perform the same as an old one.

Thanks
Derek
Title: Re: Rotational soft limit issue
Post by: Hood on August 09, 2013, 05:06:11 PM
Ok I see you are using an external controller, as far as I know Soft Limits are a function of the external controllers plugin/firmware so likely you will have to contact the manufacturers of the controller. There may be options in your plugin but as I dont have the plugin I cant look to see.
Hood
Title: Re: Rotational soft limit issue
Post by: derek on August 09, 2013, 05:12:16 PM
Hi Hood

You may be right but I'm almost positive that it wasn't a problem with the old XML. I was using the old XML when I first got it fired up and running with the new motion controller. I went with a virgin XML because I wanted to start with a clean slate. I'll load the old XML tomorrow morning and see what gives.

Thanks
Derek