Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: pzr on December 15, 2012, 01:22:48 PM

Title: Nema34 Problem
Post by: pzr on December 15, 2012, 01:22:48 PM

Few weeks ago I bought following set from Longs motor on Ebay:

So Ive got:

* Nema34 1600 oz-inch steppers - with 4 wires: A+ red, A- green, B+ yellow, B- blue
* Dm860A Microstep drivers
* Power supply 350W 60V 5.85A
* Break out board with paraller cable connected to the laptop

   I'm using Mach3 (demo for now) on Windows Xp Pro to control it.So far I wired only 1 axis using 1 power supply, 1 driver, 1 motor etc I did it according to this file you can find in attach
ments I set microsteping to 1/8

   And here is my problem: The engine runs very rough and tends to jerk and stall. Changing Velocity and Acceleration in Mach3 doesn't help - believe me or not I've spent many days (and nights) trying different settings.To eliminate possible problems I've used other 3 motors, power supplies, rivers etc - problem still the same .So there is no problem with the set itself - I reckon.
   I run mach3 Driver test but I don't know what to think about it - mean during the test most of the time program says: system stable,excelent and occasionally pulse too slow or too fast - but there is no test results on finish like on any other test programs - so I'm a bit confused in this matter too.

 Here is a YT link wich shows how the engine spin:

Is there any mistakes you reckon I made?? I have no more idea how to set it up to get better result

Any comments will be helpfull. Thanks Yaz
Title: Re: Nema34 Problem
Post by: Hood on December 15, 2012, 01:36:13 PM
Your description of the driver test sounds like you have problems there, what does the line look like in the driver test?
Title: Re: Nema34 Problem
Post by: rrc1962 on December 15, 2012, 11:08:00 PM
A laptop is not the most stable platform to be running Mach3...unless you're using an external motion controller.  Looks like you're using a PP.  Try reversing the state of "Step Low Active" for the axis in question.  If that doesn't help try a desktop PC.
Title: Re: Nema34 Problem
Post by: jimthefish on December 16, 2012, 09:09:51 AM
I have the same system (motor, stepper drives and power supplies from China) and they work fine on an old Dell desktop PC and converted Triac mill. Just a couple of thoughts.
Have you a parallel port connection in the back of your laptop and not one of those PP to USB cables? Secondly I noticed in you video the motor keeps running when you take your finger off the computer key, that suggests a delay in the signal reaching the motors. I'm sure its your computer pulse signal output. I know they suggest using a smoothstep connection between your computer and BOB. As Hood suggests find someone with a desktop and as them if you could load Mach3 demo on it to try your system, if it still gives you problems you know its not your laptop.
Hope this helps
Title: Re: Nema34 Problem
Post by: jimthefish on December 16, 2012, 09:25:28 AM
Ok you know when you have just pressed the post button and then have another thought. When I was setting up my system I wired up the 4 wires from the motor into the stepper drive wrong (this was because the original Denford Triac had the wrong colour coding on the electrical drawing) so I cross phased the motor coils, that gave me a sound like a concrete mixer full of bricks. Use an multimeter to check you have the correct pairs of connections into your stepper units. The pairs of wires should give you a connection reading.
Again good luck, its going to be something simple. Jim
Title: Re: Nema34 Problem
Post by: pzr on December 16, 2012, 12:50:00 PM
Thank you for all your replies.

Started to thinking the problem is with my laptop or driver settings. When I run the driver test, the pulsing is all over the place - far away from straight line:(
It varies between too slow, excellent and too fast etc
I have tried every possible settings for the parallel port in the bios, but the results are the still same

Checked the motor wiring with multimeter and seems to be fine

My next step is to try use PC instead of laptop and see if that help
Title: Re: Nema34 Problem
Post by: Hood on December 16, 2012, 01:11:43 PM
 the slow response is due to slow acceleration/deceleration in the motor tuning.

 It is almost certain a problem with the pulsing, that is what I thought from your initial description of the driver test and is why I asked what the line was like in it.
As has been mentioned laptops are very often problematic as they have a lot of power saving features in them which can often not be turned off by the user. This is the reason Artsoft does not officially support laptop use unless it is used in conjunction with an external controller.