Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: DHay13 on July 12, 2012, 10:50:23 PM

Title: spoilboard surfacing
Post by: DHay13 on July 12, 2012, 10:50:23 PM
Finally started up my machine tonight. Tried to surface my spoilboard using the surfacing program in the Mach 3 wizard. I have my machine home set at the front left corner. My axis' are correct in that when I hit X+ and Y + they move away from the home corner. I set my job home to the corner of the spoilboard next to machine home. My work area is 24"x24" but my spoilboard is more like 22"x24". The X axis dimensions are correct but the Y goes past the ends of the spoilboard. This is not a big deal but I am mentioning it for reference. So my job home is at about X1.0 and Y1.0. I put the cutter bit where I want the work home to be then zero all work axis' then hit regen toolpath. The problem is that my job home is at X and Y about -4.8***. My machine then tries to go to the negative and hits the soft limits. The only way I could get it to work was to put the job home at about X and Y +5.1***. The toolpath would then go back towards my job home and start the cut. I have tried several times to reset my job home but it doesn't seem to change. I have set the Surface Wizard program to be 24"x24" and have also tried down to 15"x15". It still puts job home past the machine home and hits the soft limits.

I can probably figure it out with more messing around but just wondered if anyone had any suggestions.   
Title: Re: spoilboard surfacing
Post by: Hood on July 13, 2012, 04:25:51 AM
Attach your xml and the code you are using.
Title: Re: spoilboard surfacing
Post by: DHay13 on July 13, 2012, 11:01:55 PM
I'll have to get it in the morning and post it up.
Title: Re: spoilboard surfacing
Post by: DHay13 on July 14, 2012, 04:47:20 PM
Think I figured it out. The surface program had a wrong setting. I don't have Mach 3 on this PC and I don't remember exactly what it was but something to the effect of the minimum X value in the wizard was set at -5. I changed that to 0 and it seems to be running fine now. Not sure why it did that. If my work area is set at 0, 0 then why would it go to -5? In the toolpath tab it had read that the range was -4.8?? to something. After changing the setting it now reads a minimum of 0 and a maximum of +23.8.

I am running it now and all seems good so I'll let you know how it works. I'm using a small 1/4" flute bit so it will take quite a while to cover a 24"x24" area. I have my tool speed set at 9" per minute and can't seem to get it any higher. I would think that doing a .1" deep cut I could go faster than that.
Title: Re: spoilboard surfacing
Post by: DHay13 on July 14, 2012, 09:31:44 PM
Everything started out good. I began surfacing my spoilboard and it looked good. I fixed the feedrate issue too. What is a good feed rate for wood? I ended up at 36" per minute. The problem I ran into this time was near the end of the Y axis. It got to about +22 and acted like it had hit the stop. I still had at least another inch of travel left but it was clicking like the coupler was slipping. I looked around and couldn't find anything in the way. I checked my home and limit configs and noticed the Y was set at 23" but I doubt that was causing it since the motor was still trying to go further.

Another thing that seemed odd was that I have my machine home set to the left front corner. When I hit 'Go to Z' it went to the right front. I'm 99% sure it went to the left front before. Not a big problem but curious.
Title: Re: spoilboard surfacing
Post by: Hood on July 15, 2012, 04:06:27 AM
Sounds like your motor may have stalled. Could be there is a tight spot in your axis or simply your acceleration/velocity are too high or your motors are not powerful enough.
Title: Re: spoilboard surfacing
Post by: DHay13 on July 15, 2012, 09:47:48 AM
Thanks Hood. I have to check a little closer but I am at the end of my Y travel. There is still a couple of inches before the Y assembly hits the end but I lifted it up and looked underneath and I have less travel than that before the ballscrew hits so I think that is what is happening. Have to look at it a little closer to be sure. Doing home renovations so I don't have a lot of time to mess with it but hopefully I can get down there later to look it over.