Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: DonH on May 07, 2011, 05:52:29 PM

Title: Slowdown limit
Post by: DonH on May 07, 2011, 05:52:29 PM
On the Bridgeport series 1 quill there is a slowdown limit ahead of the home limit. The home limit has very little over-run.

How can I configure the slowdown limit to decelerate the Z so it does not run into the home limit at full speed when referencing the axis?

This has probably been discussed before,but I have not  found it.

Title: Re: Slowdown limit
Post by: Hood on May 07, 2011, 06:20:54 PM
Normally you will do homing at a reduced feedrate, how reduced will depend on your rapid speed and velocity but I found 80% was fine although most tend to use 40% or so.

Slowdown during rapids is best handled by setting up softlimits and then setting a slow zone, the distance of the slow zone will again be dependant on your machines setup but something around 5 to 10mm (0.200 to 0.400") will be fine.

You set all these values by going to Config menu then Homing and Limits.
Title: Re: Slowdown limit
Post by: BR549 on May 08, 2011, 02:04:05 AM
On the series 1 cnc if you overun the upper Z limit switch you can lock up the quill and damage the screw.

Best to use the slow down switch to tell mach to slow to 50% of the home speed as it trips the switch.

You would set up the input to mach and use a macro or brain to monitor the switch value. Then thru the macro/brain tell mach to slow down.

I have an old macro here somwhere I will look it up for you if needed.

Just a thought, (;-) TP
Title: Re: Slowdown limit
Post by: DonH on May 08, 2011, 05:35:31 PM
Thank you Hood & BR549 for the replies.

BR549...That is along the lines I was thinking. If you can send me the macro it would be very much appreciated. Have not got into macros yet but could not quite see how to achieve it with a brain. The documentation is a bit sparse to say the least.

Title: Re: Slowdown limit
Post by: BR549 on May 08, 2011, 08:34:04 PM
This is the macro code to monitor the Z slowdown switch. First you set up your inoput in mach (turn on ,set port/pin)

Then place this code inside the Macropump.  It monitors the switch and IF it goes avtive setsets the RefSpeed if it is not active it reset the ref speed back to normal.

If  Isactive(input1) Then        ' Monitor input 1  IF the input goes active then

DoOemButton(1001)                'Feedhold
While IsMoving
Wend                             'Wait until it stops

DoOemButton(1003)                'Stop

Setparam( "Zrefper",25)         ' Set Ref speed to ()% of rapid
DoOemButton(1024)                'Restart Zref


SetParam("Zrefper",50)           'IF the input does not go active then set Ref speed to 50% of rapid
End If

NOW as Hood mentioned you SHOULD be very conservative of your homing speeds with the Z as NOT to overrun the switch too far. The slowdown is a backup NOT a reason to overspeed the Zref function. Heck you only have 5" of travel anyway whats the hurry.

Hope that helps, (;-) TP
Title: Re: Slowdown limit
Post by: Hood on May 09, 2011, 05:09:53 AM
Personally I have never had an issue on the Bridgeport, homing I do at 80% and softlimits with a slow zone protect fine once homing has been done. I have never had the Z ballscrew stick and I did crash it a few times before I had the limits set up but maybe I was just lucky ;)
Title: Re: Slowdown limit
Post by: DonH on May 10, 2011, 07:19:03 AM
I will incorporate the macro as I am not the person who will be using the machine.

Ihave a lot to learn about Mach3, but the documentation takes a little while to locate and I find the old grey matter a bit slower than when I started with valve & transistor mainframe computers in the early 1960s.

Many thanks,  Don
Title: Re: Slowdown limit
Post by: deanq on May 11, 2011, 10:29:48 AM
I encountered these two limit switches also when I retro'd my series I Bridgeport. Hood has what
I think is the best option and is what I incorporated. Use the highest switch as your limit and set up a soft limit, in my case .5" before encountering the hard limit. Just abandon the pre-limit switch. as the soft limit is performing this function (less problems). JMHO.