Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: stitchlips on August 09, 2006, 12:20:33 AM

Title: strange holes
Post by: stitchlips on August 09, 2006, 12:20:33 AM
I am not sure if thisĀ  is the right forum. If it is not I apologize. I am testing out a program for carving. I output the gcode to mach 3 and then test it there. I am getting these weird holes from the z axis and it doesn't happen when the z axis is a set depth, this happens when it move up and down.
Anyone know why this happens?
(http://www.siliconesoapmolds.com/images/deepholes.jpg)
Title: Re: strange holes
Post by: Graham Waterworth on August 09, 2006, 03:19:25 AM
Looks very odd.

Post the G-code so we can have a look at the z moves.

Graham.
Title: Re: strange holes
Post by: stitchlips on August 09, 2006, 03:29:22 PM
( V-Carve 1 )
( Mach2/3 Postprocessor )
N20G00G20G17G20G90G40G49G80
N30G70
N40T1M06
N50G00G43Z0.5000H1
N60S16000M03
N70G94
N80X0.0000Y0.0000F100.0
N90G00X1.5110Y2.2980Z0.2000
N100G01Z-0.0315F30.0
N110G01X1.5132Y2.3108Z-0.0276F100.0
N120X1.5198Y2.3341Z-0.0209
N130X1.5291Y2.3557Z-0.0149
N140X1.5343Y2.3646Z-0.0129
N150X1.5458Y2.3803Z-0.0101
It seems to happen around line n110 - n140.

I am not sure. I could have all of the settings in mach 3 messed up.  This was suggested in another forum.

"You might want to check your Mach 3 settings. If your setings for your Z axis is not correct then you can possibly get
more movement then the VCP toolpath actually tells it to."

I am not sure how to check my setting for the z axis. I am completely new to this so excuse my ignorance.
Thanks
Title: Re: strange holes
Post by: Graham Waterworth on August 10, 2006, 04:15:44 AM
Are all the holes at the Z plunge in point of all the different cut sections?

Graham.


Title: Re: strange holes
Post by: stitchlips on August 10, 2006, 11:56:22 AM
Are all the holes at the Z plunge in point of all the different cut sections?

Graham.



Sorry I don't understand your question.
Title: Re: strange holes
Post by: Graham Waterworth on August 11, 2006, 04:06:18 AM
In the picture on your first post,  are the 'stange holes' where the cutter starts cuttting that section?

Title: Re: strange holes
Post by: stitchlips on August 11, 2006, 09:51:20 AM
In the picture on your first post, are the 'stange holes' where the cutter starts cuttting that section?



Yes and I think I have figured it out. I had the some settings wrong for my z axis too many steps so it was going deeper than it was supposed to but only on z.
Thanks