Hello Guest it is January 18, 2022, 05:02:56 AM

Author Topic: Driver Installation question  (Read 28578 times)

0 Members and 1 Guest are viewing this topic.

Re: Driver Installation question
« Reply #10 on: November 26, 2007, 01:04:41 PM »
On my machine, the StepOverY value causes the gantry to move in a hesitant, slow and go motion.  Is this normal? 

So if the video frame rate is constant, there will be more frames during the gantry slow period.  Maybe you take that into consideration, or will I expect a denser cloud of points at each slowdown of the gantry?

And maybe I should get my system up and running so I can find out for myself :)

Thanks for your reply. 
« Last Edit: November 26, 2007, 03:15:19 PM by DavidCousins »

Offline ART

*
  • *
  •  1,702 1,702
  • Tough as soggy paper.
    • View Profile
Re: Driver Installation question
« Reply #11 on: November 26, 2007, 02:04:16 PM »
The slow startr/stop moves are normal, its moving, waiting for a frame, then digitizing 640 points, then moving again..  Lost frames done matter, it only needs one when it needs one..
Re: Driver Installation question
« Reply #12 on: November 26, 2007, 03:14:38 PM »
If my camera resolution is less the 640x480, is that OK?   If it is less, then Mach3 will digitize less data, is that a correct statement?

Offline ART

*
  • *
  •  1,702 1,702
  • Tough as soggy paper.
    • View Profile
Re: Driver Installation question
« Reply #13 on: November 26, 2007, 04:01:31 PM »
yes , it uses whatever you give it..
Re: Driver Installation question
« Reply #14 on: December 01, 2007, 02:54:56 PM »
The slow startr/stop moves are normal, its moving, waiting for a frame, then digitizing 640 points, then moving again..  Lost frames done matter, it only needs one when it needs one..

Art,
I was just rereading your post and I gained some clarity the second time around.   Your program/routine does not actual capture a movie, rather it captures a frame of data, a single frame, and processes it into 640 points. That actual frame of the video is then discarded.  Then you move the gantry equal to the StepOverY value and process a new frame.  Again you analyze and process 640 points, discard that frame and move to the next capture point.   All the movie frames in between are lost.  How am I doing?   

I can't wait till my new laser pointers arrive. 
Thanks for inspiration
Dave

Offline ART

*
  • *
  •  1,702 1,702
  • Tough as soggy paper.
    • View Profile
Re: Driver Installation question
« Reply #15 on: December 01, 2007, 03:13:20 PM »
Yup, thats how it works..

Art
Re: Driver Installation question
« Reply #16 on: December 03, 2007, 02:57:02 AM »
hi every time i try to start the video window or video probe i get DRIVER WATCHDOG TRIGGERED what is this & can i get over it?
thanks mick winship
Re: Driver Installation question
« Reply #17 on: December 03, 2007, 05:07:49 AM »
hi every time i try to start the video window or video probe i get DRIVER WATCHDOG TRIGGERED what is this & can i get over it?
thanks mick winship
Mick,
What version of Mach3 are you running?  It must be R2.60. 
I take it that you have a camera installed?  Is the camera installed correctly?  Does the camera's video software run without Mach3 and run correctly?   
Dave

Offline ART

*
  • *
  •  1,702 1,702
  • Tough as soggy paper.
    • View Profile
Re: Driver Installation question
« Reply #18 on: December 03, 2007, 09:16:51 AM »
Hi:

 Just select config/general, and turn off "Use Watchdogs" , thatll cure it..

Art
Re: Driver Installation question
« Reply #19 on: December 04, 2007, 02:51:30 AM »
hi thanks for the reply !! i left the machine alone for a couple of ours when i came back & tried again everything works fine in both the video window & the video probing window it must have been having an off day
cheers for the reply