Hello Guest it is December 08, 2021, 02:33:47 AM

Author Topic: PoKeys homing limit switch issues  (Read 4921 times)

0 Members and 1 Guest are viewing this topic.

PoKeys homing limit switch issues
« on: February 18, 2018, 05:40:15 PM »
I am about at the end of my rope on getting Mach3 to home properly with PoKeys. I just installed a PoKey 57E interface card. I have all the motions running correctly and the limit switches all working. I have the Limit + and limit - wired in series with the home limit switch being the limit- switch. The switches come in and triggers just fine.

When I try to run to REF ALL HOME in Mach3 it runs to the Z - limit switch and stops and gives me a limit switch triggered error and stops. It will not back off the limit switch.

Is there a configuration I am missing? In Mach3 or pulse engineV2?

Thanks
Schrubber
Re: PoKeys homing limit switch issues
« Reply #1 on: February 18, 2018, 09:34:33 PM »
Hi Schrubber, Make sure you are homing the Z in the positive direction also know as up.
There is a setting to allow you to auto override the limit switch, otherwise you need to go to the settings tab on the main page or hit Alt-6 to get there. You have the option of manually overriding the limits every time it happens or select the auto override function on the same page.
HTH
Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: PoKeys homing limit switch issues
« Reply #2 on: February 19, 2018, 12:06:28 AM »
The Mach3 plugin doesn't support it, but you can go in PoKeys application, open Pulse engine settings and configure the 'back-off' distance after homing. Make sure that you click 'Save configuration' so that the settings are stored in the device. Mach3 plugin will not override this setting.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: PoKeys homing limit switch issues
« Reply #3 on: March 02, 2018, 08:11:21 PM »
i am attempting to setup mach3 with poyeys 57cncdb25 trying to set up limit switch back off. and soft limits and slow down.  i set up in the application tab with no success  what do i set up in the app there is a lot of info duplicated . what is necessary what is not needed  

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: PoKeys homing limit switch issues
« Reply #4 on: March 03, 2018, 04:32:27 AM »
You do not need to configure anything else in PoKeys application other than the back-off distance, which is not supported by the Mach3 plugin.

You will find the setting somewhere in the middle of the screen under 'Homing' options. Enter the number of pulses you want the motors to back-off from the home switch. Note that this configuration must be done for each axis separately. Once done, click 'Save configuration' button on the right.

Everything else is configured via Mach3 plugin.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: PoKeys homing limit switch issues
« Reply #5 on: March 03, 2018, 11:14:33 AM »
i entered as stated when z axis hits switch it stops  i have to reset and move axis manually

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: PoKeys homing limit switch issues
« Reply #6 on: March 04, 2018, 12:55:36 AM »
How many pulses did you specify? Did you update the firmware to the latest one available (4.3.14)?
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: PoKeys homing limit switch issues
« Reply #7 on: March 05, 2018, 10:38:43 AM »
i updated firmware ,the pulse setting is at 2000  until i can get it to work then i will fine tune settings .It still goes to z switch and stops  with open switch signal on motor 3 Note all of setting i put in mach and plugin show up in the pulse engine app.

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: PoKeys homing limit switch issues
« Reply #8 on: March 05, 2018, 02:26:00 PM »
How did you configure the limit and home switches in Mach plugin?
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: PoKeys homing limit switch issues
« Reply #9 on: March 05, 2018, 02:46:15 PM »
X-p13 L++  13-- Ac low , shared with limit     Y- p 11 L++ 11-- act low ,shared with limit   Z-p15 L++  15-- act low  ,Shared with limit  A-Slaved to y  P 13++   L-- 12 act low, shared with limit