Welcome, Guest. Please login or register.
Did you miss your activation email?
December 22, 2014, 04:08:32 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Mach Discussion
| |-+  General Mach Discussion
| | |-+  Heeeelp: My stepper motors only turn in one way
Pages: 1   Go Down
Print
Author Topic: Heeeelp: My stepper motors only turn in one way  (Read 3098 times)
0 Members and 1 Guest are viewing this topic.
tonidnc
Holding

Offline Offline

Posts: 2


View Profile
« on: April 11, 2008, 01:13:22 PM »

Hi everybody:

I'm new here and in cnc world. First of all, sorry for my poor english, I'm from Barcelona, Spain, so please be patien, jejeje.

I'm trying to upgrade a manual lathe to cnc with Mach3. I have two stepper motors (one with 8 wires 640 oz/in and another with 6 wires 180 oz/in) and a Gecko 201 and a KL 4030 from kelinginc. I have the same problem with booth axis, x and z.

With manual Jog I can make them turn but just in one way. But I checked with a Led the state of the direction pin and the port pin switches between HI and LO state, in order if it is turning clockwise or counter clockwise.

Anybody can help me??

Any help is welcome

Thanks to everybody..

Toni
Logged
tonidnc
Holding

Offline Offline

Posts: 2


View Profile
« Reply #1 on: April 11, 2008, 03:21:24 PM »

Hi everybody:

I fixed the problem!!!!!

I just tied all grounds togheter. First, I linked the grounds from the two power supplies. Now I added togheter the parallel port ground. Now everythign works nice.

I hope this will help for anybody.

Thanks everybody

Toni
Logged
cadzukes
Holding

Offline Offline

Posts: 1


View Profile
« Reply #2 on: October 16, 2011, 07:50:37 PM »

I'm using a similar kit and have the same problem.  So far I'm only testing the X stepper.

What should I be grounding?
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!