Welcome, Guest. Please login or register.
Did you miss your activation email?
June 24, 2018, 06:14:54 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Third party software and hardware support forums.
| |-+  Newfangled Mill Wizard (Moderator: Ron Ginger)
| | |-+  Mill Wizard Feed Rate
Pages: 1   Go Down
Print
Author Topic: Mill Wizard Feed Rate  (Read 310 times)
0 Members and 1 Guest are viewing this topic.
Keldar
Active Member

Offline Offline

Posts: 4


View Profile
« on: June 08, 2018, 09:28:25 PM »

I have a question about the feed rate that the wizard puts out. Everything looks good except it inserts a feed rate equal to the plunge rate just before the main G code. I have attached an example of the code. It is easy to fix just by editing it out but I wonder why it puts it there. Thank you for any insight on this.

* Test Feedrate1.tap (0.83 KB - downloaded 15 times.)
Logged
Ron Ginger
Active Member

Offline Offline

Posts: 920



View Profile WWW
« Reply #1 on: June 08, 2018, 09:51:10 PM »

I am not sure what you see. the comments show you have a feed rate of 322.5500 and a plunge rate of just 0.5. That sounds really strange, did you enter those values in the tool screen? I dont think the program would have calculated such values.

I dont see the code using that plunge rate anywhere.  Please give me the line number where you see  that.

Code:
(posted for Aluminum )
(Strategy: Equal )
(Rapid height: 1.0000  Clearance height: 0.0500 )
G98 G80 G17 G90 G54 G64 G91.1

G21 G90
(***New Tool Selected***)
(ToolNum: 01  Diameter: 3.0000  )
(Feed: 322.5500  SFM: 152.0000  Plunge: 0.5000  ChipLoad: 0.0100  )
M06 T1 ()
G43 H1
M03 S16128
(***Cut Rectangle***)
(Groove)
(Xorign: 5.0000  Yorign: 0.0000  Length 2.0000  Width: 2.0000  CorR: 0.0000  InOut: 02  )
(Ztop: 0.0000  Zdepth: -0.5000  Zstep: 0.5000 )
(will make  1.0000  cuts of:  0.5000 )
(Rotated around X,Y orign by 30.0000 degrees)
G00 Z1.0000
X4.0000 Y1.7321
Z0.0500
G01 Z0.0000 F322.55
F0.50
Z-0.5000
X5.7321 Y2.7321
X6.7321 Y1.0000
X5.0000 Y0.0000
X4.0000 Y1.7321
G00 Z1.0000
M09
M05
M30 (end of file)


Logged
Keldar
Active Member

Offline Offline

Posts: 4


View Profile
« Reply #2 on: June 08, 2018, 10:07:28 PM »

If you look just after the Line "G01 Z0.0000 F322.5" the wizard inserts F0.50 just before the main run to make the cut.
Logged
Ron Ginger
Active Member

Offline Offline

Posts: 920



View Profile WWW
« Reply #3 on: June 09, 2018, 06:24:49 AM »

OK, sorry, I missed that line. Should stop reading forums after bedtime.

the "G01 Z0.0000 F322.55 " is doing a rapid drop to the surface of the work- its still above the work, in the air, so I move rapid to save time.
Then the F 0.5 is  issued because we are at the surface and starting to plunge into the work.
The next move is the plunge to the first cut so we must use the plunge rate.

The error in the code is that we should then issue a feedrate  because we start to make X,Y moves. In fact because of the model nature of G01, all the following G01 moves will be to slow.

You want to edit the code to add an F322.5 to the line "X5.7321 Y2.7321 "

I thought this got fixed some time ago, but to be honest I have not made an update in some time. Are you running the latest version?
Logged
Fledermaus
Active Member

Offline Offline

Posts: 137


View Profile
« Reply #4 on: June 09, 2018, 10:02:03 AM »

Hi Ron

This has been a sore for ages and was not fixed in the latest version. It would be great if you could fix it soon, thanks

Allan
Logged
Keldar
Active Member

Offline Offline

Posts: 4


View Profile
« Reply #5 on: June 09, 2018, 12:49:44 PM »

Thanks for the replies. I was wondering if I was just missing something in the set up. Not a big deal to correct now that I know.
Logged
Keldar
Active Member

Offline Offline

Posts: 4


View Profile
« Reply #6 on: June 09, 2018, 12:55:29 PM »

Ron I'm running 2.0.4X according to the about in help. I did download the latest version from Newfangled. It indicates version 2.0.5 in the download file name. I did uninstall the previous version first but it still came up in about saying " 2.0.4X"
Logged
Ron Ginger
Active Member

Offline Offline

Posts: 920



View Profile WWW
« Reply #7 on: June 09, 2018, 01:12:11 PM »

I believe 2.04X is the latest. I will talk to Brian about fixing this.
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!