Welcome, Guest. Please login or register.
Did you miss your activation email?
April 21, 2018, 04:36:00 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Third party software and hardware support forums.
| |-+  PoKeys (Moderator: NeoTO)
| | |-+  PROBLEM WITH MPG IN POKEYS57
Pages: 1   Go Down
Print
Author Topic: PROBLEM WITH MPG IN POKEYS57  (Read 102 times)
0 Members and 1 Guest are viewing this topic.
JORATORCA
Active Member

Offline Offline

Posts: 30


View Profile
« on: April 11, 2018, 01:40:58 PM »

Hello everyone.
I am finishing my pendant to control my CNC milling machine manually. It is developed from a Pokeys 57 device. It has a tactile keyboard that controls all functions, a 4x20 character LCD and an MPG.
Everything works well with a macropump except the MPG. It has a very strange behavior, since I am only able to make it work if I set the MPG1 and MPG3 in Ports and Pins and in the Pokeys mapping, I encode the Fast Encoder 1 that I have connected in pins 1 and 2, so that I can manage the DRO103: MPG3 count DRO. In this way, if I move the encoder, I see the pulse count in the Pokeys IO Status and in the Settings tab of Mach3.
The problem is that the axis selector that I have written in the macropump logically does not work and to select the axis that controls the MPG I have to do it through the button of the interface of Mach3 or by pressing ALT + C on the keyboard.
My version of Mach3 is R3.043.066 and the Pokeys plugin is verison 3.15 of 2/28/2018.
If I only select MPG1 in Ports and Pins the axes move alone without control.

I have read and reread all the forum posts related to PoKeys and MPG and I have not found anything similar.

Can you help me?

Sorry for my bad english ...


* 20180410_230938.jpg (1540.86 KB, 2560x1440 - viewed 8 times.)

* Captura1.PNG (65.89 KB, 835x475 - viewed 8 times.)

* Captura2.PNG (14.07 KB, 654x200 - viewed 9 times.)

* Captura3.PNG (18.8 KB, 705x417 - viewed 10 times.)
Logged
JORATORCA
Active Member

Offline Offline

Posts: 30


View Profile
« Reply #1 on: April 12, 2018, 03:46:49 PM »

Tonight I discovered the reason for the strange behavior of my pendant. It turns out that a brain that I designed some time ago remained active and interacted with the MPG1. I disabled the brain and everything started to work perfectly.
Thank you all
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!