Welcome, Guest. Please login or register.
Did you miss your activation email?
October 21, 2017, 04:08:18 PM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Mach Discussion
| |-+  Mach4 General Discussion
| | |-+  Modbus DL05
Pages: 1   Go Down
Print
Author Topic: Modbus DL05  (Read 125 times)
0 Members and 1 Guest are viewing this topic.
menardmfg
Active Member

Offline Offline

Posts: 16


View Profile
« on: October 12, 2017, 03:10:30 PM »

Can anyone help me, Iím trying to connect a DL05 to Mach 4 via the modbus. Iíve got the outputs working fine but I canít seem to make the inputs work. When I check the modbus diagnostic window I keep getting a 131 invalid reply error. What am I missing? Iím running mach4 industrial.

Thanks
Art
Logged
menardmfg
Active Member

Offline Offline

Posts: 16


View Profile
« Reply #1 on: October 12, 2017, 07:12:37 PM »

Thanks, I figured it out
Have a sparkling day
Art
Logged
Steve Stallings
Mach4 Alpha

Offline Offline

Posts: 283



View Profile WWW
« Reply #2 on: October 12, 2017, 08:50:12 PM »

Please tell us more, so the next guy can find the solution by searching here.

Promise we will not laugh if it was something obvious.... 8~)

Logged

Steve Stallings
www.PMDX.com
For PMDX product support, please use PMDX forum or direct email for quickest response. We do not use this forum as our primary product support site.
menardmfg
Active Member

Offline Offline

Posts: 16


View Profile
« Reply #3 on: October 17, 2017, 10:38:47 AM »

Hey Steve,
Iíve learned a few things about USB interface. Iím using the automation direct serial to USB adapter. First you need to pay attention to the communication setup. I used the default for the DL105. Which is 9600 baud, 8 bits, odd parity and one stop bit. Next you need to decide which port on the DL105 to use. I started with port 1. That is where I think my problem started. It seemed to work fine for outputs but wouldnít read inputs. I changed to port 2, I also used slave address 1 in Mach while setting up the functions. And everything is working fine. I am finding that if you change USB ports in your computer It changes the com port in your device manager, it can increase the port higher than port 4 which is the highest you can use in Mach. Iím not real happy about that, so I ordered a PCI serial card. I hope this helps others.

Thanks
Art
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!