Welcome, Guest. Please login or register.
Did you miss your activation email?
October 19, 2017, 10:01:47 PM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Mach Discussion
| |-+  Brains Development
| | |-+  Was the problem ever fixed where Local Var inputs cause Mach3 to hang?
Pages: 1   Go Down
Print
Author Topic: Was the problem ever fixed where Local Var inputs cause Mach3 to hang?  (Read 380 times)
0 Members and 1 Guest are viewing this topic.
Jim Bridgeman
Holding

Offline Offline

Posts: 1


View Profile
« on: August 04, 2017, 11:38:36 AM »

From what I have read in the forum, as far back as 2008 it was reported that using a local variable as an input to a brain would cause Mach3 to hang.  Was this problem ever resolved? I am using Demo Version R3.043.066 for my code development and it exhibits the problem.

Thanks.

-Jim
Logged
damo green
Active Member

Offline Offline

Posts: 16


View Profile
« Reply #1 on: September 01, 2017, 02:53:37 PM »

I could not get a COMPARE block to compare a digital/boolean switch to activate even though I could see the switch input toggle between 1/0 in the Brian viewer.....
     so I set up to inputs , one was the switch input 1/0 and the other as a variable=1  and then tried to compare those two (after a no-operation pass thru)  and yes, my mach3 hung up...and may bot even allow my PC to open that profile without crashing...it think i may have to remove the offending Brain from the folder.....stand by.....
 
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!