Welcome, Guest. Please login or register.
Did you miss your activation email?
April 29, 2017, 04:29:15 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Third party software and hardware support forums.
| |-+  PoKeys (Moderator: NeoTO)
| | |-+  unable to obtain maximum scan rate
Pages: 1   Go Down
Print
Author Topic: unable to obtain maximum scan rate  (Read 311 times)
0 Members and 1 Guest are viewing this topic.
machiner
Active Member

Offline Offline

Posts: 52


View Profile
« on: April 15, 2017, 02:26:17 PM »

I have been  adding functions on to my Pokeys 57E , and the Device load went up and up
Now the Device Load Status screen is at 100 and the app says ' Maximum scan rate cannot be obtained '.  

Refer to attached screenshots  for hardware , software and configuration data.
i am running the latest Mach4 unlicensed, on a Mac Boot Camp Drive. (I5 1.4 GZ).

when I de-activate the pulse engine the 'load' drops to under 100 percent and
the message goes away and device load status drops to 78 percent.

See ' Device load status  window’ . note the 'drop' in the graph. thats when i turned
        the pulse engine off and then on. '

I need every inout and output i can get ,  i am using 48 of the exBus outputs
three high speed and one ultra high speed encoder and a 4 x 8 key-input matrix
plus the pulse engine.

question zero
is this a big problem ? does this  mean trouble when i try to make chips.
or can i ignore the 'warning'.

question one:
is the 57CNC faster ? will it manage the above load any better
or will i need a second 57E to handle some of the IO.

question two :
Will Mach4 handle Dual 57's,  one for IO and one for pulse ?

question three:
are there any tricks to reduce load ?
i don’t need high speed on the matrix inputs
or on the 48 outputs ?


thanks in advance


* pokeys app.JPG (95.9 KB, 612x847 - viewed 20 times.)

* pulse engine.JPG (138.87 KB, 868x779 - viewed 20 times.)
« Last Edit: April 15, 2017, 02:28:44 PM by machiner » Logged
bru102
Active Member

Offline Offline

Posts: 6


View Profile
« Reply #1 on: April 16, 2017, 11:00:05 AM »

This may be irrelevant to your question, but I noticed all error inputs are lit up, and I saw that yesterday. You have "external pulse generator" selected, but NOT "Extended I/O".  I ran into that yesterday when things wouldn't work.  The 57cnc manual says "Pulse generator options: PoKeys57CNC contains an external pulse generator on-board, thus external pulse generator option with ‘Extended IO’ must be selected."
Logged
machiner
Active Member

Offline Offline

Posts: 52


View Profile
« Reply #2 on: April 16, 2017, 04:08:54 PM »

Thanks for your response.

I Have a 57E, Not a 57CNC. For step drivers I use the PoExtBusOC16CNC,
which  has no External Outputs. I could set it for 8 step motors but I only use 4.


I trust someone will comment if This pulse engine configuration is incorrect for my setup.
I will run some tests on alternate configurations, and notify if that helps at all.
Logged
bru102
Active Member

Offline Offline

Posts: 6


View Profile
« Reply #3 on: April 16, 2017, 05:13:46 PM »

Missed that detail....  Good luck with it.
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!