Welcome, Guest. Please login or register.
Did you miss your activation email?
March 26, 2017, 11:59:25 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Third party software and hardware support forums.
| |-+  PoKeys (Moderator: NeoTO)
| | |-+  PoKeys57CNC, spindle speed measurement jumps like hell
Pages: 1   Go Down
Print
Author Topic: PoKeys57CNC, spindle speed measurement jumps like hell  (Read 146 times)
0 Members and 1 Guest are viewing this topic.
Comet_SL9
Holding

Offline Offline

Posts: 2


View Profile
« on: March 18, 2017, 07:12:16 PM »

Hi folks,

I'm new to the forum, but got a decent (and probably not easy to solve) issue: I've got a PoKeys57CNC and just converted my lathe from an parallel port interface. For spindle speed measurement, I use a CNY 37 with an index disc, directly mounted on the spindle. This setup worked quite well with the parallel port interface so far (including threading on my lathe under mach3).

Now, after re-wiring everything, I've got signal levels from on the output of the CNY 37 between 0.04 V (low) and 2.3 V (high). It is wired to the index input to the PoKeys57, Pin 13 (Encoder I). Those signals look quite nice on the oscilloscope, right frequency. When looking at the PoKeys diagnostic screen, Pin 13 is turned on and off when turning the spindle by hand - fine so far. I've configured the spindle speed measurement in the Plugin configuration as "Index (lathe)" with 1 tick per rev. Threading support is turned on. Spindle feedback ratio is set to 1

Now to the strange thing: When (and only when) the spindle is turned, at exactly each pass of the index hole, the measured and in the DRO "True RPM" displayed value for the true spindle speed jumps like hell between totally arbitrary and quite large values. That is true for all rpms from nearly DC (turning by hand) to its max speed of 2000 rpm.

Those speed measurement values are so large that when turning with constant surface speed, the axes of the lathe always run at full speed - which for sure is no option for working with it.

Anyone got a good idea how to solve this jumpy behavior of the index? I've got already a low-pass-filter infront, but that does not help.

Attached are some pics, also a youtube video: https://youtu.be/7k_iY3MVh2Y

With best regards,
    Carsten


* IMG_20170319_003248.jpg (1072.18 KB, 3264x2448 - viewed 11 times.)

* IMG_20170319_003324.jpg (1075.83 KB, 3264x2448 - viewed 8 times.)
Logged
Comet_SL9
Holding

Offline Offline

Posts: 2


View Profile
« Reply #1 on: March 22, 2017, 04:59:17 PM »

I just want to document the solution to everyone. Obviously, it was an EMC problem in my control box. Steps to the solution:

1. Increase the ultra fast encoder filter setting in the mach4 plugin settings to 100.
2. Add a (~22 kHz) low-pass filter to the CNY37 output.
3. Add a Schmitt-Trigger behind the filter.

Attached is the schematic, which will do the job and give a very stable spindle speed measurement.

Regards,
    Carsten


* Spindel_Index.png (18.8 KB, 1545x1065 - viewed 9 times.)
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!