Welcome, Guest. Please login or register.
Did you miss your activation email?
October 21, 2018, 06:58:07 PM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Third party software and hardware support forums.
| |-+  Third party software and hardware support forums.
| | |-+  Xhc HB04 MPG Pendent with Mach4
Pages: « 1 2 3 4 5 6 7 8 »   Go Down
Print
Author Topic: Xhc HB04 MPG Pendent with Mach4  (Read 29143 times)
0 Members and 2 Guests are viewing this topic.
mkullman
Active Member

Offline Offline

Posts: 39



View Profile
« Reply #60 on: January 08, 2018, 07:34:12 PM »

so I took a closer look at their "driver"  and it is not a driver, it is a plugin. they are using the default HMI driver that comes with windows.
I attempted to do the same thing but had issues so I had to make a more explicit call to the WINUSB driver by making an INI file, telling windows which driver to use.

I am at a loss as to what the issue on your machine is because I cannot seem to duplicate the issue on any of my computers (Win7, Win8.1 & Win10).
it almost seems like windows is ignoring your request to uninstall the driver.

All I can think of is try using a windows restore point or maybe try installing the driver for the actual Shuttle-pro over my driver.
Logged
Peter Knell
Active Member

Offline Offline

Posts: 69


View Profile
« Reply #61 on: January 25, 2018, 08:03:04 PM »

mkullman, did the other user you were emailing get back to you about how he went with the XHC WHB04B?
If not im ready to pull the trigger on the older version in wireless and use your driver.
Thanks
Logged
mcbride19
Active Member

Offline Offline

Posts: 7


View Profile
« Reply #62 on: February 24, 2018, 10:40:01 AM »

mkullman.
Thanks a lot for your work, I've just received my WHB04B and it works well with your drivers.

just a question: when shut down the WHB04B start it again I must restart mach4 or else it doesn't work anymore, do you have a clue of what's going wrong ?

Thks

Logged
Peter Knell
Active Member

Offline Offline

Posts: 69


View Profile
« Reply #63 on: February 25, 2018, 02:13:19 PM »

Mcbride19 are you using the old version of the WHB04B (white and blue buttons) or the new version of the WHB04B (orange and blue buttons). I havent purchased yet but if you have it working i might get it. Thanks
Logged
mkullman
Active Member

Offline Offline

Posts: 39



View Profile
« Reply #64 on: February 26, 2018, 01:08:56 AM »

hey guys, sorry i have been slow to reply. I'm in the process of building a house and have a hundred pot's on the fire.
@Peter Knell, Yes I did hear back from him. He said he has moved on to another job and did not keep any of the files from his previous workplace. again, if you message me, I'll send you what we had when we parted ways. we had it mostly working, there were just a few minor things left if i recall correctly.

@McBride, I have the same issue with the plugin running on my window's 7 machine. Mach refuses to fully shutdown for some reason and has to be shutdown via task manager. I've been poking at it for a while with no success.
Logged
mcbride19
Active Member

Offline Offline

Posts: 7


View Profile
« Reply #65 on: February 26, 2018, 01:18:23 AM »

Don't worry for the "slow reply"  we are all having much more important thing to do Wink
You already made a fantastic work for us.

thks for the answer
good luck for the building ...
Logged
Zaidron
Active Member

Offline Offline

Posts: 5


View Profile
« Reply #66 on: March 19, 2018, 03:07:15 PM »

@mcbride19
So the WHB04B also just works with mkullman's plugin and driver?
Does all buttons and functions of the pendant work?
Can you setup the macro buttons for it (macro 8,9,10)
Logged
mcbride19
Active Member

Offline Offline

Posts: 7


View Profile
« Reply #67 on: March 21, 2018, 04:55:39 AM »

Yes it works .
Not all the function are working but the moSt of it are working and as I can see Mkullman is still working on his plugin so we just have to be patient. Wink
For now this plugin is fantastic and far better than the xbox plugin  :p
Logged
mkullman
Active Member

Offline Offline

Posts: 39



View Profile
« Reply #68 on: March 24, 2018, 02:05:11 AM »

er... I think there may be a bit of confusion here.
the driver linked to above should not work for the "B" variant.
it should only work for the WHB04 not the WHB04B
I do have a kludged driver for the WHB04B. I had to code it in the blind, because I don't have the pendent to be able to test it on. So it is kind of one of those "use at your own risk" things. in theory it should work, but if it opens a portal to Hades...  Undecided ...message me if you want to try the WHB04B driver.
While I'd love to be spending more time helping everyone get their XHC pendants working under Mach4, my life is a hurricane at the moment and I have very little time to play with this stuff.
Logged
mcbride19
Active Member

Offline Offline

Posts: 7


View Profile
« Reply #69 on: March 24, 2018, 02:17:39 AM »

Sorry, yes there is a little confusion, i's the wired version that works with the driver , the WHB04B is the wireless version.And , of course, I have the wired version,
« Last Edit: March 24, 2018, 02:20:26 AM by mcbride19 » Logged
Pages: « 1 2 3 4 5 6 7 8 »   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!