Welcome, Guest. Please login or register.
Did you miss your activation email?
September 22, 2018, 10:03:59 PM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Third party software and hardware support forums.
| |-+  Contec (Moderator: smurph)
| | |-+  Contec Plugin not working
Pages: 1   Go Down
Print
Author Topic: Contec Plugin not working  (Read 25044 times)
0 Members and 3 Guests are viewing this topic.
sun123
Holding

Offline Offline

Posts: 1


View Profile
« on: November 21, 2012, 02:35:33 AM »

After installing the contec DLL correctly in mach3 plugin folder, when I try to open mach3 it showing "Plugin DLL Defective.Reload & PIO16.dll-defective plugin found,igonring" like this.So can anyone send me a right DLL file for CONTEC PIO-32/32.

Regards
Jeffin
Logged
smurph
Active Member

Offline Offline

Posts: 985


"That there... that's an RV."


View Profile
« Reply #1 on: April 29, 2013, 12:18:38 AM »

The Contec plugin requires that you have the Contec DIO drivers installed on your PC.  You can download them from their web site.

The plugin is not defective.  Mach gives that message for any reason it cannot load a plugin. 

Steve
Logged
smurph
Active Member

Offline Offline

Posts: 985


"That there... that's an RV."


View Profile
« Reply #2 on: January 24, 2018, 02:39:05 PM »

The reasons are:

1.  A plugin may require a third party DLL that is not present on the system.
2.  These third party DLLs may require a hardware driver that must also be installed. 
3.  These third party DLLs may also require system DLLs that were not installed at the time the OS was installed.  Or the DLLs may have been removed if the user "stripped" down the OS.  A common one is the Printing subsystem.
4.  A plugin may not be able to "find" these required components (even if they are installed on the OS) unless they are put in the PATH environment variable. 

In all of these cases, the plugin will be reported as "defective".  All that message really means is the plugin could not load due to some missing requirement.  Perhaps the message could be worded a little differently. 

In the case of the Contec cards, the correct PCI driver needs to be installed.  When installing any plugin, the user must ensure that the hardware and associated drivers and software (API libraries) are there for the correct operation of the device.  Most of the time, there are tools that come with the hardware to verify the correct operation. 

https://www.contec.com/download/donwload-list/?itemid=8f8212f8-2dc1-4605-afd4-2d4867e50873#software

Steve
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!