Welcome, Guest. Please login or register.
Did you miss your activation email?
August 23, 2017, 06:39:01 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Mach Discussion
| |-+  Mach SDK plugin questions and answers.
| | |-+  Finished Plugins for Download
| | | |-+  USB JoyPad and game device plugin - New Version 2.0
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 »   Go Down
Print
Author Topic: USB JoyPad and game device plugin - New Version 2.0  (Read 143578 times)
0 Members and 1 Guest are viewing this topic.
polska
Active Member

Offline Offline

Posts: 27


View Profile
« Reply #90 on: December 14, 2012, 12:34:08 PM »

Hi All,
Since last weekend I have downloaded the JoyPad v2.0 rar file 3 different times extracted with proper software,  and for some reason I have difficult time to install the JoyPad.m3p plugin. Tried in two different computers one is running WinXP with all the updates included the .net and win installer and second PC running Vista. I'm getting "access is denied" message in Vista compute,r and "not found" on other running XP. The JoyPad.exe is running and so the manual PDF file. I tried the plugin install from desktop, Mach3 folder, and the plugin folder it self. NO JOY!  Sad I'm out of ideas...  I the past I was able to install few plugins and never have any issues in doing so. This one does not want to play. Multiple times rebooting the computers didn't help either... Any ideas ?...  Any suggestions/help would be MUCH APPRECIATED. Thanks.
Logged
atifeh
Active Member

Offline Offline

Posts: 19


View Profile
« Reply #91 on: December 14, 2012, 12:47:13 PM »

Hello Polska,

What was the exact "not found message" on WinXP?
Please be advised that you should install all the required .NET's. The lateset version would not suffiice.

Regards
Logged
polska
Active Member

Offline Offline

Posts: 27


View Profile
« Reply #92 on: December 14, 2012, 01:54:07 PM »

Hi Atifeh,
Thank you for quick response. The exact message in XP is "not found"..  Reinstalled  .net file with correct 3.5 version of the .NET file. Still the same message 'not found' ..

Best..
Logged
atifeh
Active Member

Offline Offline

Posts: 19


View Profile
« Reply #93 on: December 14, 2012, 02:43:10 PM »

Hello Polska,

Have you installed .NET versions: `1.1 , 2.0, 3.0 too? On one occasion I found that these should also be installed.
Also please Check in your Settings/Add-Remove Programs to see if .NET's are installed properly.

Regards,
Logged
polska
Active Member

Offline Offline

Posts: 27


View Profile
« Reply #94 on: December 14, 2012, 04:20:19 PM »

Thanks again for quick reply Atifeh. Reinstalled the Mach3 and the plugin installed OK.

Best.
Logged
polska
Active Member

Offline Offline

Posts: 27


View Profile
« Reply #95 on: December 16, 2012, 04:15:30 PM »

Hi All,
 The plugin loaded fine , calibration is was done, but in order to use joystick the sequence in with the Alt button and the joystick activation is reversed . So after pushing the joystick and pressing the Atl button the X or Y axis starts at maximum speed. Very unsafe. Frankly I'm plane Jane no peanuts guy . I liked allot  plugin that was written by Art, it was good enough for what I need. could move X-Y axis safely when I want it to... Now after installing a ESS the plugin no longer works. I wish Art would resurrected it. I appreciate the effort put forth by all the people who created it, but for my way of thinking the joystick usage should plain and simple and just be able to move the axis safely..    
Logged
atifeh
Active Member

Offline Offline

Posts: 19


View Profile
« Reply #96 on: December 16, 2012, 05:59:44 PM »

Hi Polska,

You can reduce the maximum jogging speed as a percentage of the maximum speed. You have set it near 100% of the max. speed.

Regards,
Logged
polska
Active Member

Offline Offline

Posts: 27


View Profile
« Reply #97 on: December 16, 2012, 06:51:29 PM »

Hi atifeh,

Sorry I wasn't very clear in my explanation. I'm aware of the option settings in the plugin configuration area. Full rapid speed is not the problem. The problem I'm having is the joystick is not operating as the PFD manual says it should operate.  To use the joystick the sequence in with the Alt/Shift button and the joystick activation is reversed, according to the manual Shift and Alt buttons are considered safety buttons and used to activate the two joysticks. Shift activates continuous jogging and Alt activates step jogging.. First the Shift button should be depressed and I should be able to make the axis move with the joystick.. Not the other way around like I'm forced right now. Joystick wide open first and then press the button..
Logged
area51
Active Member

Offline Offline

Posts: 98



View Profile WWW
« Reply #98 on: December 16, 2012, 10:27:10 PM »

Hi Polska.

If I understand the problem correct, the joysticks will allow movement even when the Alt and Shift safety is unpressed?
(Normal operation is continuous movement if Shift is pressed and step movement if Alt is pressed when joysticks are activated).
If yes, what is the button states in control panel for button 5, 6, 7 and 8 (they should all be off when unpressed)?

If there is a bug in the plugin I would like to fix it...

- Joakim

Logged

Visit the JoyPad plugin Home at http://joakim.dk/joypad for the latest version and info.
polska
Active Member

Offline Offline

Posts: 27


View Profile
« Reply #99 on: December 17, 2012, 08:04:37 AM »

Hi Polska.

If I understand the problem correct, the joysticks will allow movement even when the Alt and Shift safety is unpressed?

No, The axis moves only after SL/SR or AL/AR is pressed as it should be. As I understand I should first press either of those buttons and then proceed with joystick.
In my case it does work in the opposite way Activate joystick and the n press the button in order to see the axis respond..

(Normal operation is continuous movement if Shift is pressed and step movement if Alt is pressed when joysticks are activated).
If yes, what is the button states in control panel for button 5, 6, 7 and 8 (they should all be off when unpressed)?

If there is a bug in the plugin I would like to fix it...

I got a hunch the problem lays on my side, either I'm doing something wrong or the joystick it self is faulty, although it does calibrate like it supposed to
during calibration.

- Joakim



@ Joakim
Could I ask for a favor? Could you Sir write a simple plugin just for XYZ movement based on the same joypad? Those two joystick(B3 B4) movable actuators provide enough variable speed
in itself to be able maneuver safely.. B3-XY axis, B4 Z axis...

Appreciate the help
Logged
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 »   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!