Welcome, Guest. Please login or register.
Did you miss your activation email?
October 22, 2014, 08:49:20 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
+  Machsupport Forum
|-+  Mach Discussion
| |-+  General Mach Discussion
| | |-+  MACH3 MOTOR TUNING
Pages: 1   Go Down
Print
Author Topic: MACH3 MOTOR TUNING  (Read 8442 times)
0 Members and 1 Guest are viewing this topic.
mrpeja
Active Member

Offline Offline

Posts: 108


View Profile WWW
« on: April 10, 2009, 01:02:50 PM »

Hi,
There is a situation:
I have plasma table, step motor 400 steps/rev, gear ratio 1:5 and rack and pinion 30 mm pitch diameter. Here is my calculation:
400 * 5 = 2000 steps/revolution of pinion,
path per one revolution of pinion: 30 * pi = 94,347779 mm
path per step: 94,347779 / 2000 = 0,0471 mm.
steps per unit (mm): 1 / 0,0471 = 21,22.
So far so good.
Now Motor Tuning in Mach3:
I put 21,22 steps per unit (mm), and velocity 4000 mm/min (what is 66,66 mm/sec)
Step frequency will be 21,22 * 66,66 = 1414 Hz
But motor run to slow and oscilloscope measurement shows step frequency about ten time slower, e.g. 135 Hz!
Who is mistaking, me or Mach3?
PLEASE CONTROLL MY CALCULATION
Regards,
mrpeja
Logged
Hood
Mach4 Alpha

Offline Offline

Posts: 23,673


Carnoustie, North Britain (formerly k/a Scotland)


View Profile
« Reply #1 on: April 10, 2009, 02:42:45 PM »

What kind of drives do you have? Do they have microstepping?
Hood
Logged
mrpeja
Active Member

Offline Offline

Posts: 108


View Profile WWW
« Reply #2 on: April 11, 2009, 12:52:50 AM »

Hi Hood,
No, I don't have microstepping. I have bipolar motor, working in half step mode. So, 400 steps per revolution and 0,9 deg per step.
It's urgent!
mrpeja
Logged
Hood
Mach4 Alpha

Offline Offline

Posts: 23,673


Carnoustie, North Britain (formerly k/a Scotland)


View Profile
« Reply #3 on: April 11, 2009, 04:08:17 AM »

Ah ok thought maybe that was the case but just wanted to check that you were not using a 0.9 degree stepper.
 Your calcs seem to be fractionally out but not enough to make the difference you are seeing.
(400 steps per motor rev, 5:1 gearing is 2000 steps per pinion rev, one rev is 93.477795mm so 2000/93.47775=21.39545.......... per mm or unit)
 If your commanded speed is is much slower then maybe you possibly your rack or gearing is different. Not sure where you were scoping the pulse stream from but if it was the output of the drives  try disconnecting the parallel port cable and check direct on the port, obviously the motors wont move but at least you will get the true pulse stream.

Hood
Logged
mrpeja
Active Member

Offline Offline

Posts: 108


View Profile WWW
« Reply #4 on: April 11, 2009, 08:15:28 AM »

Hi Hood,
PROBLEM SOLVED!
First, I'm experienced electronics engineer and I can help about electronics, if somebody need.
I measured directly on parallel port, and frequency was like I said.
But  problem was on another place! I assumed when I jog, travel must be at maximal speed. But is not. I accidentally pressed Home axis bar and motor runs fast. So, I only need to find where to adjust jogging speed.
Thanks for your efforts to help me.
 Best regards
mrpeja
Logged
MachineMaster
Active Member

Offline Offline

Posts: 151


View Profile
« Reply #5 on: April 11, 2009, 11:20:03 AM »

Do you have Home Switches installed? I have noticed that if an external E Stop is triggered that Jog speed is slow until I Home the machine.
If there are no Home switches, try double clicking the "Normal Condition" bar just above the feed rate box.
Logged
Hood
Mach4 Alpha

Offline Offline

Posts: 23,673


Carnoustie, North Britain (formerly k/a Scotland)


View Profile
« Reply #6 on: April 11, 2009, 12:38:37 PM »

Press the Tab key on your keyboard and the flyout screen has a Slow Jog rate DRO, set that to 100% and it will jog at the velocity in motor tuning. If you wish to retain the slow jog you can override it by pressing the shift key while you jog.
Hood
Logged
mrpeja
Active Member

Offline Offline

Posts: 108


View Profile WWW
« Reply #7 on: April 11, 2009, 12:53:47 PM »

Hi,
I found jogging go slow because slow jog rate is set to 20%. When I jog holding Shift key then is going fast
mrpeja
Logged
Pages: 1   Go Up
Print
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!