Welcome, Guest. Please login or register.
Did you miss your activation email?
October 26, 2014, 02:41:30 AM

Login with username, password and session length
Search:     Advanced search
* Home Help Search Calendar Links Login Register
  Show Posts
Pages: 1 2 »
1  Mach Discussion / General Mach Discussion / Re: when / why to dereference axes? on: June 01, 2013, 01:50:09 PM
that clears it up, thanks Hood.
2  Mach Discussion / General Mach Discussion / when / why to dereference axes? on: June 01, 2013, 12:09:48 PM
I am not a professional machinist so please forgive my ignorance.

As I understand it, "referencing" an axis means to "home" the axis.  I understand that this moves the axis to its home position and sets the DRO to 0.  This indicates to the operator that the machine knows its position with respect to that home position.  I do this every time I turn on the machine. 

The "Using Mach3 Mill" document says that "The De-Ref All button does not move the axes but stops them being in the referenced state."

When and why would I push that button?

Thanks...
3  Mach Discussion / General Mach Discussion / Re: Mach3 Tool Display "squashed" for 4-axis Gcode?? on: December 25, 2012, 10:06:59 PM
Thank you Greolt...
I have now set things up as you suggest. 
I wish your post could be pinned or the info captured in a FAQ for the benefit of everyone!

Regards,
Dean
4  Mach Discussion / General Mach Discussion / Re: Mach3 Tool Display "squashed" for 4-axis Gcode?? on: December 25, 2012, 11:35:43 AM
thank you Greolt.  I do remember setting the rotation radius some time ago (a suggestion I read on the web) to make the ratoray table spin faster.  I did not realize it would have an efect on the display.

If I set the rotation radius to zero and the steps per inch of the A-axis motor to the manufacturers specifications, the display is correct but the A-axis rapids and feedrate is about one tenth of the specified feedrate.  I suppose the correct adjustment is the A-axis velocity in Motor Tuniing....
Regards,
Dean
5  Mach Discussion / General Mach Discussion / Re: Mach3 Tool Display "squashed" for 4-axis Gcode?? on: December 24, 2012, 04:35:57 PM
awesome... thank you Hood.
6  Mach Discussion / General Mach Discussion / Mach3 Tool Display "squashed" for 4-axis Gcode?? on: December 24, 2012, 03:54:17 PM
I am using a licensed Mach3 with a Taig 4 axis Milling profile (generally with the 2010-4 screenset but this problem exists with the 1024 screenset as well). 
When I load a 2D or 3D Gcode file everything appears at correct scale in the toolpath display window.  But whenever I load a file which has A axis moves, the file appears "squashed" in the toolpath display window.  I have attached a screen capture of one of my files as it appears in Mach3 and as it appears in another simulator.   Why does Mach3 "squash" the display this way?  I have no axis scaling enabled.

If someone is willing... could you load the attached Gcode into a 4-axis Mach3 profile and let me know if it displays correctly for you?

Thanks....
7  Mach Discussion / General Mach Discussion / Re: mach 3 (scripter compile error.in:) message using thc301 screen set on: April 16, 2012, 01:23:18 AM
Darren,  I have had that same error message appear from time to time, and then it goes away, and the button works normally.
My conclusion is that Mach3 sometimes corrputs its profile so no matter if you exit the program and restart, or uninstall the program and reinstall, if you load the corrputed profile something internally gets in a wrong state and the trouble reappears.   In my case other wierd things happen at the same time, like the program all of a sudden switched from inches to mm or the machine co-ordinates are way out of bounds... obvious signs of something getting corrupted.   Do you see "other wierdness" as well?
My advice would be to recreate your profile from one of the defaults, or try it restoring a backup of the profile if you have one.
8  Mach Discussion / General Mach Discussion / Manual Limit Override won't shut off?? on: March 11, 2012, 06:33:08 AM
I am trying to figure my problems out before posting questions, but I am having a heck of a time trying to figure out why the Manual Limit Override LED is on and why it wont turn off.
My machine co-ordinates (X,Y,Z,A) are all well away from their soft limit ranges, diagnostics screen shows none of my home switches are triggered,  I have pressed RESET and tried to jog further off (I can in fact jog all axes).

I have tried disabling soft limits altogether, I have tried disabling Auto Limit Override....
I have tried exiting and relaunching Mach, rebooting the computer,  even downgrading to the lockdown version of Mach3.  It still loads with the Manual Limit Override flashing and won't shut it off.

I am using R3.043.058 with SmoothStepper v17efb.  My settings XML file is attached but renamed with a .txt file extension.  A screen capture of my co-ordinates & diag screens are also attached.
Any ideas what's going on here??
thanks.....
9  Third party software and hardware support forums. / Newfangled Solutions Mach3 Wizards / Re: unlicensed wizard file after installation on: March 09, 2012, 01:05:41 PM
solved:    my Mach3 was running in demo mode.  The Wizard needs both a wizard licence file and a Mach3 license file.

Thanks for all your help.....
/Dean
10  Third party software and hardware support forums. / Newfangled Solutions Mach3 Wizards / unlicensed wizard file after installation on: March 09, 2012, 12:01:49 AM
ok so I received the WizLic.dat file and installed it into the C:\Mach3 folder.
It is in that folder not a subfolder, and that is my Mach3 installation folder, and it is really named WinLic.dat.  there is no hidden file extension on the end.
I completely exited and restarted Mach3.
I can invoke the Newfangled wizard (v2.79) and can create a circle cut operation and can verify toolpath to preview the Gcode (screenshot attached here).
But when I post the code and exit back to Mach3 I get the message "Unlicensed Wizard FIle" followed by the message "unknown word where unary operation could be".

How do I get the Newfangled wizard to accept the license file?  There is no indication that it found the .dat file, or that it failed to decrypt it, or that there was a version mismatch .....
Pages: 1 2 »
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!