Hello Guest it is September 16, 2019, 09:11:04 AM

Author Topic: Can not get off the limit switch  (Read 7695 times)

0 Members and 1 Guest are viewing this topic.

Can not get off the limit switch
« on: May 03, 2008, 03:01:02 PM »
Hi I am new to CNC and am having trouble with my home/limit switches.  I only have my x axis powered up.  On my X axis I have two switches, x-/home and x+ limit.  When I reference the table moves negative unitil it hit the -x/home switch and stops, all good.  But I can not get it to move off the limit/home switch.  The override limit on the setting tab does not seem to work.  I can keep hotting that button and it will not turn green.  I have tried the auto override and it does not work.  What am I doing wrong? 

Thanks,
Todd

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can not get off the limit switch
« Reply #1 on: May 03, 2008, 03:02:45 PM »
Are you pressing the reset button? If not you need to press that to stop it flashing before you can jog off the limit.
Hood
Re: Can not get off the limit switch
« Reply #2 on: May 03, 2008, 03:34:08 PM »
I tried that but the reset just keeps on flashing.  The only way i can get it to stop in to manually move the table of the limit and then press the reset. 

Thanks,
Todd

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can not get off the limit switch
« Reply #3 on: May 03, 2008, 03:40:12 PM »
Can you attach your xml, if you are using the standard profile you will find it in your Mach3 folder, it is Mach3Mill.xml. You will need to copy it to another location on your hard drive and then rename it before the forum will accept it as an attachment, I suggest trh.xml as a suitable name to change it to. To attach a file you need to use the full reply form then choose the additional options button at the lower left.

Hood

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Can not get off the limit switch
« Reply #4 on: May 03, 2008, 04:36:58 PM »
Hi, Todd

Settings Page, "Over-Ride Limits", Turn it "ON", Reset, Jog off switch should work.

Hope this helps, Chip
Re: Can not get off the limit switch
« Reply #5 on: May 03, 2008, 05:04:16 PM »
Do you have the Limit Override enabled in the Config--->Ports & Pins ---> Input Signals?  I had the same prob with limit overides until someone clued me in to enabling it.

HTH,
Sid

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can not get off the limit switch
« Reply #6 on: May 03, 2008, 05:12:28 PM »
Sid you shouldnt need that enabled unless you are wanting to use an external button.
Hood
Re: Can not get off the limit switch
« Reply #7 on: May 03, 2008, 05:16:09 PM »
Hmmm, OK.  Thanks- ya learn sumpthin new everyday!

Sid
Re: Can not get off the limit switch
« Reply #8 on: May 03, 2008, 07:55:47 PM »
Thanks for all your suggestion.  I have attached the XML file Hood.   I have also broken out the scope and started looking at signal.  The 5 volts on the breakout board in not reel clean so I am starting to look at power.

Thanks again,
Todd

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can not get off the limit switch
« Reply #9 on: May 03, 2008, 08:06:55 PM »
Just tested your xml and it seems to work fine here, granted I dont have it on a machine but when I change the active state of one of the limits so that Mach thinks its triggered I am able to press the Limit Override then reset and jog away. Set the debounce Interval at 2000 and see if that lets you jog away, could possibly be noise that makes Mach think the limit switch is constantly going on/off.
 Hood