Hello Guest it is September 20, 2019, 11:26:29 PM

Author Topic: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders  (Read 18386 times)

0 Members and 1 Guest are viewing this topic.

Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« on: April 09, 2016, 09:03:52 AM »
Greetings,


i would need some help regarding the CSMIO/IP-A. The problem is in the PID regulation. When i try to regulate the axis i do not recive any signal from the linear encoder on the graph . Is this normal? Linear encoders are Heidenhaim ls 903. I have checked the connection and every thing is connected right. Attached you will find  data sheet of the encoders and my screen of the problem. The encoders worked with the old controller without problems.



Thank you in advance.


https://www.dropbox.com/sh/5zyu75x5e756ku1/AADZO8KOkRyX_a6qm7OCSv-pa?dl=0

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #1 on: April 09, 2016, 02:06:47 PM »
Are your scales 5v square wave?
Often Heidenhain Encoders and Scales are sine wave 1v peak to peak, if so then they are no use unless you also have an additional interface box that I have seen on some systems. That box takes the sine wave signal and converts to 5v square wave.
Hood
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #2 on: April 09, 2016, 02:29:43 PM »
Hood thanks for the answer. How can i check this ? I have loked at the data sheet that i atached but i coudl not find anything. The suppy is 5 V  Do you have any idea who sells these boxes? If i understand correctly than the signal has to be square ?

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #3 on: April 09, 2016, 03:05:46 PM »
Ok just looked, they are sine wave scales.
Do they have an additional box that came with them that they plug into or did they just plug directly to the old CNC   control?

I have seen them on eBay but even second hand they are expensive.

You would probably be cheaper just getting compatible scales or using the motors encoders if it has them, if it is resolvers then might be better just to get encoders and fit to the ballscrews.
Hood
Hood
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #4 on: April 10, 2016, 03:43:53 AM »
No they were direct plunged in the old controller. I do not have encoders on the motors. What i have to lok when i buy buy new linear scales?

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #5 on: April 10, 2016, 04:10:19 AM »
If you look here and scroll down you will see the specifications you need.
http://www.ebay.co.uk/itm/JCXE-linear-encoder-glass-scale-for-digital-readout-650-mm-to-950-mm-travel-/221901376880?hash=item33aa5a4d70:g:mw4AAOxyOMdS9inu

As I said the other option would be to fit encoders, it may be the cheapest depending on the axis lengths.
Hood
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #6 on: April 10, 2016, 06:11:13 AM »
Thanks Hood. Can you check if these linear encoders would be ok. Because we use them at work and i know they are good.
http://tela-ms.si/doc/NC%20linear%20scales%20TGM133_173.pdf

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #7 on: April 10, 2016, 06:24:27 AM »
From what I see, there are 3 versions of each of these scales. two seem to be sine wave, one mA (SI) and the other Volts.(SV)
 They will not be any use.

The third kind however (DS) seems to be square wave and although it doesn't give the voltage it says RS422 which I think would suggest 5v but you would need to clarify that with the manufacturers.
Hood
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #8 on: April 10, 2016, 10:36:02 AM »
Will borov tomorrow a linear encoder. See what happens. Thanks hood i will update as soon as i connect the encoder.


Regards.
Re: Motor tunning with CSMIO/IP-A (PID) Trouble with encoders
« Reply #9 on: April 12, 2016, 11:18:54 AM »
Okay i borrowed the linear encoder at work and see attachment first response when i move it with hand. Tomorrow i will order new ones. Does anybody know how to remove the x axis linear encoder ( see atachment)

Regards

Rok

attachments :https://www.dropbox.com/sh/5zyu75x5e756ku1/AADZO8KOkRyX_a6qm7OCSv-pa?dl=0